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1

Key Features

Moxa MXview network management software gives you a convenient graphical representation of your Ethernet
network, and allows you to configure, monitor, and diagnose Moxa networking devices. MXview provides an
integrated management platform that can manage Moxa networking devices, such as Ethernet switches and
wireless APs, and SNMP-enabled and ICMP-enabled devices installed on subnets. MXview includes an
integrated MIB complier that supports any third-party MIB. It also allows you to monitor third-party OIDs and
Traps. Network and Trap components that have been located by MXview can be managed via web browsers
from both local and remote sites—anytime, anywhere.

The following topics are covered in this chapter:

0 Web-based Operation
O Auto Discovery and Topology Visualization
0 Event Management

O Configuration and Firmware Management
a

Traffic Monitoring



MXview Key Features

Web-based Operation

MXview uses the client-server model. You will need to install the MXview server on a Windows computer
connected to the network(s) that are to be managed. After installing MXview, the network can be managed with
Internet Explorer or Firefox, without installing additional software.

Auto Discovery and Topology Visualization

Within the scan range, MXview locates networking devices with SNMP or ICMP services enabled. MXview can
collect topology information from devices with LLDP capability and draw the topology of the network, which
shows physical connections. For ICMP devices without LLDP, MXview’s advanced auto-topology function can
verify the connection relationship through ARP algorithms, and help you create an accurate drawing of the
network topology. If any managed PoE switches are in your network, the PoE power output information will also
be visualized automatically (for more details on PoE visualization, refer to the PoE Power Consumption
Visualization section in Chapter 8.)

Event Management

For troubleshooting purposes, MXview logs events that match preset conditions, such as link up/down, device
unreachable, or traffic overloading. The most recent events will show up on the dashboard. Devices and links
that generate events will be highlighted with different colors. When an event occurs, users can be notified in a
number of different ways, including SMS, email, popup window, sound, or external program.

Configuration and Firmware Management

MXview provides an interface for managing Moxa networking devices from a central location. Users can
remotely backup or update configuration files, and upgrade firmware.

Traffic Monitoring

MXview can log the network traffic of network devices that have been discovered.

1-2



2

System Requirements and Supported
Devices

The following topics are covered in this chapter:

0 System Requirements

O Supported Devices



MXview System Requirements and Supported Devices

System Requirements

The computer that MXview is installed on must satisfy the following system requirements:

System Requirements

CPU 2 GHz or faster dual core CPU
RAM 2 GB or higher

Hard Disk Space |10 GB or higher

oS Windows XP Professional,

Windows 7 (32/64-bit),

Windows 8 (32/64-bit),

Windows Server 2008 (32/64-bit),
Windows Server 2012 (32/64-bit),
Windows Server 2012 R2

Supported Devices

e MXview supports a full range of functions, such as network status, traffic log, and configuration/firmware
file management.

e For other SNMP-enabled devices, MXview supports standard management functions, such as link up, link
down, and SNMP MIBII information.

e MXview can only monitor the connectivity of devices that support ICMP.

2-2
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Installation and System Backup

The following topics are covered in this chapter:

O Installation Procedure
O Uninstallation

O System Backup
a

System Restore



MXview Installation and System Backup

Installation Procedure

1. Execute the installation program or insert the auto-run CD.

2. During the installation, you can choose the directory in which MXview will be installed and the default
language, or leave the settings at the default values.

3. For the commercial version, you will be asked to enter a license key; the license key can be found on a label
attached to the protective sleeve of the CD-ROM.

4. After the installation is complete, shortcuts for launching the MXview server will be created on the desktop
and in the start menu.

Uninstallation

1. Select Start > Control Panel, and then select Add or Remove Programs.
2. Select MXview

3. Select Remove

You can also uninstall the software by selecting
Start 2 All Programs = Moxa = MXview - Uninstall MXview.

System Backup

To back up the system database and configuration, use Project > Database Backup to save the backup files.
The Backup startup window will pop up.

The system exports the backup database to a directory. Use the following link to open the directory:
% MXviewPro_Data% \db_backup

Eventually, the Database backup completed event will appear on the Recent Events list. Right-click on the
event to show the details, which includes the file path of the backup files.

RecentEvents | AckAll | [fmacksd Lest Bty Bvents | = 0 0 ‘ 0 | ‘ All Events |

Ack 1D Source Source IP Device Alias Severity Description Time Issued
1 WXview Server 0.0.0.0 System Information  Database backup completed. store in SbHvizwPRO Data®db backupt 2012-11-02 15:28:33

Recent Events Ack All Unacked Last Fifty Events = a a a | | All Events

Ack D Source Source IP Device Alias  Severity Description Time Issued

i [Mxview Server 0.0.0.0

System Information

3-2



MXview Installation and System Backup

E e =)

Ewent IT: 1

Source: Mxview Server
Source IP: 0.0.0.0

Severity: System Information
Time Issued: 2012-11-0215:28:33
AckTime: Mone

Event Description:

Databaze backup completed, store in #h{EviewPRO Datafidb backupld(l
21102 152833

Detail Information:

£ 2 Closs

The backup folder uses the following naming convention: YYYYMMDD HHMMSS

The items included in the system backup are listed below:

e Topology

e Traffic

e Availability
e Event

e Threshold settings

e Job scheduler settings
e OID items

e Trap items

e System settings

System Restore

MXview versions 2.2 and higher supports configuration backup files, which use the file extension *db3. To
restore a system configuration from a backup file, first shut down MXview. Then, select the DB Restore tool
in Start & All Programs - Moxa = MXview - DB Restore tool. Log in using your username and password.
Next, identify where the backup files are located: (1) MXview’s archive repository, or (2) A custom specific
directory. Identify the folder where your backup files are located, and then click Restore. The MXview system
will restore the backup files.
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MXview Installation and System Backup

This process is illustrated step-by-step below:

1. Select Start > All Programs - Moxa > MXview > DB Restore tool

e eremt et e
. Launchy

.. Maintenance

I Microsoft Lync

v Microsoft Office Computer
. Microsoft Silverlight
. Moxa

Pictures

Music

Control Panel

1 MEview
DE Restore tool B Devices and Printers

L= MXview Server
& Plug-in Manager for MXview 2.2 Default Programs
[ Register MiXview to the Window:

7 Uninstall MXview Help and Support
m7 Un register MXview to the Windo
Iy PComm Lite Verl 6 -
4 Back
Search programs ond files 2 |

2. Login with your username and password

CE W)

I zer ame: I

Paszwiord: I

Cancel |

3. Choose the folder where the backup files are located

, e s

Restore from Mxview's archive repozitary | Fiestare from a specific folder I

Hizstorical backupz

D ate | Time |
2012/09/26 15:04:17

20120401 16:24:53
2012411402 28:33

Festare Cloze
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MXview Installation and System Backup

4. Click Restore

i B ————————— o =

Fiestore from Mview's archive repository  Festore from a specitic folder |

Backup Falder:

D:%20121102 152833 |

Cloze

o ==

@ Database has been restored.

MXview versions 2.1 and earlier use *.dat backup files. To restore the system database and configuration from
a .dat file, use Project > Import MXview Configuration file, and then select the backup file to restore.
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Getting Started

The following topics are covered in this chapter:

MXview Server Startup
Login

Login Messages
Account

Password Policy

QaoaaaoaaQ

Auto Installation of Runtime Environment (Java Runtime Environment)



MXview

Getting Started

MXview is implemented as a web server to realize remote management through a single portal. The following
figure illustrates the operational model.

Remote User

The MXview server runs in the background on a Windows PC and communicates with network devices using
Simple Network Management Protocol (SNMP) and a Moxa proprietary protocol that periodically polls specific
MIB data and stores data in a local database.

The MXview client uses web browsers to provide a uniform web interface that enables network operators to
access and operate over an intranet or the Internet.

MXview Server Startup

To start the MXview server, first double-click the MXview desktop shortcut. When the MXview window (shown
below) pops up, configure the listening port of the server (or leave it at the default value of 80) and examine
the runtime information. The server will launch when you click Start.

Clicking Launch Client will start the MXview client on the local computer. To learn how to use the MXview
client remotely, refer to the Login section below.

Ixview ver 2.7

- Industrial Network
VIGW Management Software
Moxa Inc. All rights reserved 2016.

Service | Info |

HTTP Port 80 [~ Disable HTTP port
HTTPS Port 443

System Status:  Stop
[v Connect to M¥view with Built4n Browser

QK | Launch Client | Stop & Quit

NOTE

Selecting “Connect to MXview with Built-in Browser” is recommended.
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MXview Getting Started

Login

To launch the MXview client, open a web browser and input the MXview server’s IP address or domain name in
the address field. Note that if the server’s listening port changes, you will need to input the IP address as
follows: http://[IP address]:[Port] (e.g. http://192.168.1.250:8080). If you are using the server computer as
the client, you may also click Launch Client on the control panel. The default account is admin. For MXview
version 2.6 and earlier, no password is required. For MXview version 2.7 and later, the default password is
moxa.

M OxA Industrial Network Management Software

Password

Visualize

Industrial Ethernet Networks = Operation Mode

Download MXview Client Download MXview ToGo App

Ei%

.’ App Store

NOTE A maximum of 10 users can log in to the system at the same time.

NOTE For remote users, downloading "MXviewClient" from the MXview server, and using "MXviewClient" to login are
recommended.
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MXview

Getting Started

Login Messages

Navigate to Project > Preferences -2 Login Notification.

2. Users can set their Login Message and Login Authentication Failure Message.

I3 Preferences

,@ User

----- ?_.?;‘ Account Management

----- ?Jaa Passward Palicy

;‘? Display

..... E Topology

----- Q Appearance

----- Q Device Appearance
----- ﬂ Security View

;@. Advanced

iy

- ;_.} System Configuration

S
40 3 Device

i .
::H;- SNMP Configuration
L

=1 5 Events

1,
:j Management Interface

Login Messages

Login Message

Login Authentication Failure Message

oK

Close
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MXview Getting Started

Account

There are 3 default accounts (admin, user and guest) with 2 different authorities (Administrator and User), as
shown below.

154 Preferences @

\p User Account Management

----- _J?.} Account Management
----- ‘-‘);0 Palicy

----- _2?} Login Motification

Account List

Active User Name Autharity
admin Administrator
user User

guest User

) Display
----- Bl Topoiogy

----- @ Appearance

EEE

----- @ Device Appearance

\,) Advanced

ey

;J;) System Configuration
N it

;J;) Device
- g !

;; SNMP Configuration

g
:._,5) Events

Create ]’ Modify ]l Remave

oK ] [ Close

Default User Name Default Password Authority

admin moxa Administrator

user - User

guest - User

The "Administrator" can change configurations in MXview, such as topology and scan range. The "User"
authority has read-only permission. For MXview version 2.7 and later, accounts can be created, modified and
removed and given different authority permissions.

NOTE Up to 100 accounts can be created.
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MXview

Getting Started

Password Policy

1. Navigate to Project > Preferences - Password Policy.

2. For the Account Password Policy, users can set a minimum length for the password and enable the

password complexity strength check.

3. For the Account Login Failure Lockout, users can set the retry failure threshold and lockout time.

A Preferences

\p User

----- 2"} Account Management
..... 2%

----- 2"} Login Motification

\? Display

..... b Topology

Password Policy and Lockout Setting

Account Password Policy
Minimum length 4
Enable password complexity strength check
At least one digit (0~9)

Mixed upper and lower case letters (A~Z, a~z)

(4-16)

----- k_‘ Appearance

| EET oA

At least one special character (~/@#5%M&*—_|;: -

----- k_‘ Device Appearance

----- k_‘ Security View

Account Login Failure Lockout

) Advanced Enable

(1-10)

w

..'"'-‘
fdg Systemn Configuration Retry failure threshold
3

-l
(.’5'- Device
.

-4(0 5 SNMP Configuration
?I-’g

SR
-0 3 Events
“’3

(0 5 Management Interface
Ve

(1-60)

[}

Lockout time (min)

oK | | Close

Auto Installation of Runtime Environment (Java
Runtime Environment)

The MXview client must run in a JRE environment. For users who do not have the appropriate version of JRE,
MXview will guide users to install the appropriate version of JRE automatically.
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Quick Start Using the Setup Wizard

MXview provides a Setup Wizard that can be used to quickly determine the network topology and handle basic
configuration tasks.

The following topics are covered in this chapter:

O Using the Setup Wizard
» Step 1: Create Group
Step 2: Configure the SNMP Community String

Step 3: Add the networks you want to scan

vV V VY

Step 4: Draw the topology
» Step 5: Set the SNMP Trap Server to get events in real time

O Virtual Demo Network



MXview Quick Start Using the Setup Wizard

Using the Setup Wizard

The wizard will launch automatically when the software does not contain any nodes. To launch the Setup
Wizard manually, select Project - Wizard. You should see the following window:

Setup Wizard @

Welcome to MXview Industrial Network Management Software Setup Wizard _

Welcome to the setup wizard.

This wizard will help you:
1. Add scan range

2. Draw Topology (with devices that support LLDF)
3. Set SNMP trap server

4 Use N-Snap to take an network snapshot.

| nNet | [ cancel

The wizard will guide you through five basic steps, described below.

Step 1: Create Group

Devices scanned by MXview can be organized into a multi-layer tree structure. Before finding devices, groups

need to be created. Root is the only default group. All other created groups are placed under the next level of
Root.

#% Setup Wizard 3]

Create Group

List of Groups
Root
Test

Create

Next I [ Cancel

5-2



MXview Quick Start Using the Setup Wizard

Step 2: Configure the SNMP Community String

MXview uses SNMP to collect device information. The default SNMP configurations are:

e Version: vl
e Read community string: public

e Write community string: private
If necessary, update this information at this time:

#% Setup Wizard X

SNMP Settings
Select SNMP version and required parameters for acquiring device information

SNMP Version ¥l v
Read Community public
Wirite Comrnunity .pr'nrate

| Next | ’ Cancel

Step 3: Add the networks you want to scan

MXview'’s operation is based on IP (Internet Protocol). Other devices in the scan range that use IP to operate

will be located and monitored.

Setup Wizard [=]

Scan Range
Add IP ranges to scan for devices

Scan Range Add Network

Delete MNetwork

[7] Active First IP Addre... LastIP Address MName Group
192.168.127.1 [192.168.127.254 |STE  |Root | | Modify Network |

Cllmport Device List

Select a device list to import to MXview

Mext l I Cancel
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MXview

Quick Start Using the Setup Wizard

Click Add Network to add a network range to scan. A window will pop up, with two tabs: Single Range and
Multiple Ranges.

Single Range: Enter the first and last IP address in the desired range. Name this range in the Name field.

Singls Range | Muliple Ronges

[+] Active

FirstIP Addrass

LastIP Addrass

MName

Group

Multiple Ranges: The Multiple Ranges tab allows you to set up a complicated subnet for scanning. Select
enable for the subnet range, similar to using a subnet mask. You can also name the scan range, as in the
Single Range tab.

) enable ) enable @ enable




MXview Quick Start Using the Setup Wizard

Another way to scan the network is to Import Device List. Click Import Device List and select a list file to
load the devices into MXview.

Setup Wizard @

Scan Range
Add IP ranges to scan for devices

Scan Range

Add Metwork

[] Active FirstIP Addre... LastIP Address MName Group -
T9ZAREAZT | fOZAGE2725E BITE Root 2B

Delete Metwork

Import Device List

Select a device listto import to Mxview
|d:1.Users‘.Desklop\Device_List | [ ]

Mext l ’ Cancel

NOTE A device’s IP address must be configured properly before it can be managed by MXview.

At this point, MXview will enter the discovery stage. The time needed to complete this stage depends on the
size of the scan range. Click Cancel at this point to exit the wizard; however, the configurations entered
previously will be saved and the discovery process will continue running in the background.

W% Setup Wizard X

Scanning
Discovering devices and topology

(ARNNARR

16%

Clicking the Cancel button will exit the wizard. But the discovering process will keep working in background.
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Step 4: Draw the topology

After all devices have been located, MXview will be able to draw the topology for LLDP devices.

Information

\i:) Divaww topologyiwith devices having LLDE)

(o [ome ]

Information

\i:) Do You Want to Auto Layout Topology?

[ o [ome ]

For devices without LLDP functionality, the topology can be drawn manually after the wizard is finished.

After all devices have been discovered and the topology has been created, click Next to continue to the next

step.
% Setup Wizard 3
Scanning

Discovering devices and topology

[IllIIllIIllIIllIIllIIllIIIIIIIIIIIIIIIIIIIIIIII

100%

Complete drawing topology. Please press the Next button to continue!

Mext ] [ cancel |

5-6



MXview

Quick Start Using the Setup Wizard

Step 5: Set the SNMP Trap Server to get events in real time

To enable real-time event generation, the MXview server’s IP address needs to be configured as a trap server.
To do this, enter the IP address of the MXview Server and then click Set to activate the change.

If this step is skipped, devices can still be monitored by polling periodically, although a time latency will be
introduced.

#% Setap Wizard X

SNMP Trap Server
Setthe SMMP trap SEMRVEr to capture events in real time

IP Address

Community String

Enter the address and the cormmunity string, or leave them empty to skip
*The process may take from a few sconds o a few minutes depending on the number of discovered devices.

*Thiz action will overwrite the original sethings of discovered devices

Mext | [ Cancel
After this point, MXview initialization is complete.
Setup Wizard IEI

Welcome to MXview Industrial Network Management Software Setup Wizard, "=«

Congratulations!

You have completed the basic configuration.
MXview has already begun to monitor your network.

Launch N-Snap to take an network snapshot.

NOTE

For quick troubleshooting in the future, follow the setup wizard to take a snapshot of your network.
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Virtual Demo Network

MXview provides a virtual demo network that can be used to evaluate many features of MXview. To activate the

virtual demo network, run Setup Wizard and select the Start Demo Network option at the bottom of the
window.

Setup Wizard @

[ -
Welcome to MXview Industrial Network Management Sofiware Setup Wizard _ "=«

Welcome to the setup wizard.

This wizard will help you:
1. Add scan range

2. Draw Topology (with devices that support LLDP)
3. Set SNMP trap server

4 Use N-Snap to take an network snapshot.

Start Demo Network

Net | | cancel |
Setup Wizard =z
Create Group

Lzt of Groups

Tirtnal Demo netwark

Root

Launching Virtual Demo Metwork @
[ ]
Scanning Available IP Addresses (1/2)
Create
Next ] [ Cancel
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Quick Start Using the Setup Wizard

M OXA === (Gigabit Ethernet

Reliable Networks = Sincere Service = Power line

Network traffic (%) \M’ffw
[)F‘—"s"a'4 £ 0 25 50 75 100 =%
MXview pR7524
Demonstration

Network

20s 651

pR-7624 ?1 @WI
’ Hw

By following the MXview Setup Wizard, you can easily build up the network environment.

Scan Range
Add IP ranges to scan for devices

Setup Wizard @

Scan Range [ I l
Active FirstIP Addre... LastIP Addre.. MName Group -

10.20.30.1 10.20.30.4 Virtual Metwork  Virtual Demo n... [ Modify Network l

[ Delete Network l

[1lmport Device List

Select a device listto import to Mxview

MNext ] l Cancel

After the Setup Wizard is done, you can experience MXview with the virtual demo network.
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-
WW@W JlelUseclzl patwons Uanzgamant Soilyre

==
Q- Search Devices ¥ Rqot W irtual Demo network

Device List
g% Root

E}J_". Virtual Demo network .

-9 10.20.30.1-Virtual_EDS-G516E ‘
¥ 10.20.30.2—Virtual_EDS-G516E
-9 10.20.30.3—Virtual_EDS-G516E 1020301 p2

Device Properties 1 Ring 1 M aster
o Alias 10.20.30.2--Virtua -
9 aMme Virtual EDS-G516E [IB
O MaC pddress O090ES52F 550 A ,.-"‘
O Availability 100_00% - o
O svslescr SHMP4T - Agent - Win 2 ,a’“' pz 10.20.30.3
O sysDbjectld 1.3.6.1.4.1.8691 7 P e
O =vstontact P
W syshane ll':,.-'"
W zvslocation Pt
O iffNumber 8 .'
® interface. 1 up  F 100M f auto ‘
® interface.2 up / 100M f auto
® interface .3 down / 100H / auto 10.20.30.2
= interface. 4 down / 100M f auto -
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Dashboard Overview

The Dashboard should appear when you log in to MXview. When using MXview, you will spend most of your
time working from the Dashboard, which is divided into the following sections:

Menu Bar

Topology Map

Device List

Device Properties List
Small Scale Topology Map
Recent Event List

Status Bar

N o u kW N

1.

(Project_View Device Link Event Tools Help )

-
WWW lleltsirlal ylatwors Mancgamani So

TIOETE

4

»| Root

Dewice List

= gy Root
W 192168.127.5 SNMP Den
~W192168.127.1 PT-76828
19216812712 EDS-40E
P 192168127 27 EDS-40€
W192168.127 34 EDS-40E
W 192168127 88 EDS-51¢
~W192.168.127 104 EDS-4C
192168127105 EDE-4C
P192168127 107 EDE-4L
W192168.127 106 EDE-40
~W192168.127.113 EDS-4C
~W182168.127111 EDS-4C
192168127108 EDS-4(
V192G 2T 1D EDS40
¥

pE
~ e
132’.1 BE8A27 107

L
;

£

Device Properties

192168127113
0 alias

O ModelNane
O MAC Address
O sysDesce

O =ysobieceId
b =ysContact
0 =ysHane

0 syslocation
B i Fimhear

198

<

192168427 10

192165027105

192468127 150

w

>

Ack =1 Source
Mxview Sen.,. 0.0.0.0
Mview Sery.. 0.0.0.0

Wldview Senv... 0.0.0.0

{[n}

4 Al : 3 O
€ ) pefa. J__® | O

2
1

Recent Events Ak Al Unscked Last Fifty Events  »

Source P

0 0 | [(anevems |

Description
“Aulo Topology' finished
“Auto Topology' stared
Miview server stared

Saverity
Systern Inf..

System Inf...
System Inf...

Time |ssued

2011-12-2615:20..,
2011-12-2615:20...
2011-12-26 15:14...

7.

Topology has been saved successiully

32337 FM

Devices (Current/ Max) : 32120

(

)

The following topics are covered in this chapter:

0O Menu Bar

O Topology Map

O Device List

O Device Properties List
O Recent Events List



MXview Dashboard Overview

Menu Bar

All operations can be accessed from the following menu bar items:

Project

Use the Project menu to scan devices with multiple IP ranges, add devices with a specific IP address, maintain
network groups, set up MXview preferences, or start the Setup Wizard. Also, you can back up data and
configurations of the monitored networks, event history, job schedules, or network topology to a local file, or
import a project file to create monitored networks on the fly.

View

Use the View menu to change the appearance of the Topology Map. For example, you can adjust the resolution
or create a topology map.

Device

Use the Device menu to configure or examine the properties of objects.
Link

Use the Link menu to delete a link or get traffic reports.

Information

Use the Information menu to examine network-wide properties.

Event

Use the Event menu to examine events and set up notifications.

Tools

Use the Tools menu to launch additional services or programs, such as Moxa IP Configurator.

MIB

Use the MIB menu to compile or browse for a third party MIB. Import third party OIDs and Traps through the
OID import manager and the Trap import manager.

Help

Use the Help menu to view license information or information about MXview.
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Dashboard Overview

Topology Map

The Topology Map displays connection relationships of monitored devices. For devices with LLDP capability,

the connections can be drawn automatically.

Root

p8
.'.
1%2’.1 68127107

i

192168127110

Aot
s
.
.’b
."
- f
1921680127 109
o? p3
P P ‘ \
T
192166127 150
1921881271137 (392188127,

e e =S

Device List

The Device List shows the Topology Map structure in tree format. Note that link information is not shown.

Type all or part of a device name in the “Search Devices” input box to only show devices whose names contain
that keyword (for example, type “EDS” to show all EDS devices, or type "EDS-G509"” to show all EDS-G509

switches in the network.

Cievice List

= I;i,h Faoot

P 192.168.127.5 SNMP Device
= W192.168.1271 PT-F528
~W192.168.127 12 EDS-408A
~TW192168.127 27 EDS-408A
~W192.168.127.34 EDS-408A
-0 192.168.127.88 EDS-518A
=0 192.168.127.104 EDS-4084
= 0192168127105 EDS-4084
=W 192.168.127 107 EDS-4084
= 0192168127 106 EDS-4084
=0 192.168.127.113 EDS-4084
=W 192.168.127.111 EDS-4084
= 0192168127109 EDS-4084
=0 192.168.127.110 EDS-4084
182168127112 EDS-408A
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Device Properties List

The Device Properties list shows the properties of the device that is currently selected. If a device’s interface
is a PoE port, the icon will change to include a yellow electric charge.

Device Properties
O Alias 192.168.129.2 EDS-F505A ﬂ
) ModelNane EDS-PS06A
) MAC Address OOS0ESD40404
0 Availabilicy 100, 00%
) sysDesce HOxXA EDS-PS06A-4FP0E
U sys0bjeccld 1.3.6,1.4.1.8691.7.41
U sysConcacc
U zysNane Hanaged Redundant Zwitch 00000
U zyslocacion Switch Location
U iftHusber 8
B8 incerface, 1 dowmn / L0OM 7 Full-duplex
#83 incerface, 2 wup  f 10M / Full-duplex
H-8 interface. 3 dowmn / 10M / Full-duplex
* 82 interface. 4 up S AWK-3121 / 10M / Full-du
H® interface. 5 up S 10H / Full-duplex j
| ]

Recent Events List

This list shows the events that have occurred most recently.

Event Count lists the total number of events of different types, with different event types identified by
different colored rectangles (e.g., red, yellow, and green, as shown in the following screen shot).

All Events is the shortcut of the menu item Event = All. When you click All Events, a window will pop up
showing all events.

Recent Events ’ Ack All ] |Unacked Last Fitty Events v| 31 | 2 | | Kl | ’ All Events l

Ack [n} 1 Source Source P Severity Description Time Issued
O 40 hxviews Server 1892.168.127.182 Information Device ICMP reachable 2011-12-26 15:26:16 »
O 38 hview Server 192.168.127.236 Information  Device ICMP reachable 2011-12-2615:26:16
O k] Mview Server 192.168.127.2584 |Information  Device ICMP reachable 2011-12-2615.26:16
O ar hxview Server 192.168.127.252 YWarning Device SHMP unreachahble 2011-12-26 15:26:16
O 36 hxviews Server 192 168.127.2583 Critical Device ICWMP unreachahle 2011-12-26 15:26:14
O 35 hview Server 192168127250 Critical Device ICMP unreachahle 2011-12-26 15:26:14
1 i | L¥) i Coarvenr AN AR0 427 208 Tt 1 r i [P ¥. 1 = IFET F il e T I B e e Y =2 I -k 1 =2 I 4 b’
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7

Device Discovery and Polling

Devices in the assigned scan range can be discovered via SNMP and ICMP protocols. After a device is
discovered, MXview will use SNMP and ICMP to poll the device periodically. To configure this function properly,
you will need to know the following information:

1. The IP addresses of the devices on the network.

2. The Read community name assigned to the devices on the network.

Changing the Read Community String

The default Read community string that is used to discover devices is public. Take the following steps to
change the value:

1. Select Project > Preferences > SNMP Configuration.

2. Enter the new Read community string.

#% Preferences

SNMP Configuration

4 SNMP Version Vi v
ppearance "
Advanced T
System Configuration Read Community public
SHMP Configuration .
Events Wirite Comrmunity |private

Ok l [ Cancel




MXview

Device Discovery and Polling

Scan Range

You can assign multiple scan networks, with each network defined by a starting IP address and an ending IP

address. MXview will discover all active devices that belong to the scan networks.

Take the following steps to add a scan network:

1. Select Project > Scan Range.
#% Network Scan Range

Scan Range

x)

Add Metwork
[] Active First IP Address

192168127 .1

LastIP Address MName

192.168.127.50 A Modify Meteork

Delete Netwark

Celeted Devices
Recover

Device IP Model Laocation

QK and Run Discovery ] Cancel

2. Click Add Network.

"% Add Network

FirstIP Address | . . . |
LastIP Address | : : : |
Mame |

Group Root w

(o] [omn]

3. Input the starting and ending IP addresses of the range, and then click OK.

4. Click OK & Discovery to start discovery.

NOTE Device discovery will require more time for larger networks. For this reason, if possible you should avoid

defining large scan ranges.
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Device Discovery and Polling

Deleting a scan network will remove the monitored devices that belong to the network. Take the following steps

to delete a scan network:

1
2
3.
4

Select Project > Scan Range

Select a row in the table Scan Range
Click Delete Network

Click OK to activate the change

Modifying a scan network will remove devices that do not belong to the new network, and discover new devices

within the new network. Take the following steps to modify a scan network:

uos e

Select Project > Scan Range

Select a row in the table Scan Range

Click Modify Network

Modify the starting and ending IP address of the range, and then click OK
Click OK to activate the change.

Deselecting the Active checkbox of a scanned network will stop device discovery for that network. Previously
discovered devices will continue to be monitored, with the current status shown on the topology map.

Import/Export Device List

By using this function, users can easily export any device into a device list, and also can import any device list

into MXview.

Import Device List

1.
2.
3.

Select Project > Import Device List
Select a list and click Open
All the devices in the list are imported into MXview

Project | View Device Link Information Ewvent Tools MIB  Help

Scan Range )
P . rlaivyors lkirzigsnant Suiiyre

Paste Device List : Root

Group

Preferences

Wizard

Import MXview Configuration File
Database Backup

Import Device List

Export Device List

Log Qut
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Root
1EAE2 12T 2 m I-H I‘E %
" LEEREER ] LEEREER Y 1Rz AZT S 12 AERAZTE LOEARIAITT 12 AERAZTE
=
Updating coordinates of device icons...
1
i |
19218212712
1. On the Topology Map, Select the devices which will be exported into the list
2. Select Project > Export Device List
3. Enter a file name and click Save
4. The device list is saved
Project | View Device Link Information Event Tools MIB Help
Scan Range
P Mo Uenzigamant Suiivzre
Paste Device List : Root
Group i
Preferences Ang 1 Wamar
Wizard &
Import Mxview Configuration File } = 122 Wl 4
Database Backup Fiox ~
]
Import Device List EL L ] " H’,.f‘;.g"
X " AL AERAZTS 02 162421 &g | 1921642
Export Device List /5 Corh
i gz 8L 5|
Log Out 4 / :
o 1918217 4 1
— - - - | Ml = - Ty B2
-9 192.168.127.10-IEX-402-SHDSL o T ——o
-9 192.168.127.11-IEX-402-SHDSL " oz renir 1
— W ANN ACH ANT 40 OO 040 122 162 47T ‘/ - A2 A3 AT AT
Device Properties i mm“r N
ADEAE2AT AL 1
O flias 102168 127 13--Mdate b
O ModelName Wiate ME3170 [l &

NOTE

The Device List can be utilized in all the software of MXstudio, including MXconfig, MXview, and N-Snap.

Device Discovery

MXview will use SNMP and ICMP to discover devices within the scan ranges. When a Moxa
device has been located, MXview will use an actual image of the device, such as the one
shown here, to indicate the device’s location on the network.
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MXview will also list detailed properties and configuration parameters, including the following:

e MAC address

e Model name

e IP address

e Netmask

e Gateway

e Trap server address

e Auto IP configuration

e Type of redundancy protocol
e Role in redundancy protocol
e Status and properties of the port
e Status of the power

e Status and version of the SNMP protocol

MXview will use one of the following graphics to indicate devices:

BAC A

Moxa devices with SNMP enabled.

Third party devices with SNMP enabled. w«)

Third party devices with ICMP enabled. [EIT[—"

The IP address and location name of the discovered device will be shown under the image of the device. Take
the following steps to change the location name:

1. Select the device
2. Select Device> Maintenance-> Configure IP & SNMP

3. Select the Basic tab and then enter the new location name.

MXview will run conduct device discovery periodically to find new devices in the scan ranges. You may also use
the following steps to conduct device discovery manually:

1. Select project > Scan Range
2. Click OK & Run Discovery

Discovered devices will be polled periodically by ICMP and SNMP. This is done for the following reasons:

1. To monitor the availability of devices.
2. To update properties and configuration parameters of devices.

3. To update traffic information, such as utilization.
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Plug-in Manager for MXview

For Moxa devices without default support by MXview, add the Plug-in Kits of these devices into MXview through
the Plug-in Manager, and the devices’ icons will be shown on the MXview Topology Map.

Select MXview > Plug-in Manager for MXview in Start menu

Enter the username and password which are the same as MXview

In Plug-Ins page, click Add and select a Plug-in Kit folder

The Plug-in models are shown in the list and successfully added into MXview

Exit Plug-in Manager and login MXview, and these models’ icons can be shown on Topology Map

u A W N =

=

=

Login @
zerM ame: |
Paszword: |
. Logn i Cancel
- Plug-in Manager for MXview 2.4 @ﬁ

Plugrins | Builin List |

- . Currently installed plug-ins

Model | Wersioh | D ezcription

|IC5-G77484 Plug-n far IC5-G77
ICS-GY7R0s-2<G 1.0 Plug-In for IC5-G77R04-2<G
ICS-GY7a2h-4=<G 1.0 Plug-In for IC5-G77524-4=5G
ICS-G7a480 1.0 Plug-In for IC5-G73484
ICS-G78R0A-Z<G 1.0 Plug-In for IC5-G73504-2<G
ICS-G782h-4=<G 1.0 Plug-In for IC5-78528,

Add.. Remove. .. |

About | Esit |
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Topology Management

The Topology Map is the core of MXview, and can be used to complete most actions. The Topology Map shows
a graphical representation of the devices in your networks, and can be used to do the following:

e Display a graphical representation of a real network.
e Show connecting relationships between devices.

e Indicate the status of devices and links.

Multi-layer Tree Structure

The Topology Map can be organized into a multi-layer tree structure of up to 5
layers. It helps users manage a large number of nodes on the computer screen.
For example, users can move nodes of the same subnet or location into the same
group. Root, which is the only one group at the first layer, exists by default and
cannot be deleted. Groups created by users are in the layer under Root. Devices
can be moved between groups. MXview uses an icon to indicate user-defined
groups:

The first layer will be shown as:

Root | subnet x [ [z = =




MXview

Topology Management

The second layer will be shown as:

Root| subnet
192.168.127 162
192.165.127 162 EDS-4084,
Foat
p2
Ring 1 Mast
l Gt
193485127 235
192.168.127 67 -\
4] p2
,
N
"\
pY
p2 '\p1
\-
\,
p1
p2
192168 127 236 192.168.127 237

R 0 B S S

The map is represented as a tabbed window, in which each tab is a group. Double clicking a group icon in Root

will open the corresponding tab.

Auto Topology and Auto Layout

For devices with LLDP functionality, MXview can draw the physical topology map, down to the port level of the
devices. For devices without an LLDP MIB, MXview is able to draw links by using ARP. To activate this function,

select the Advanced Topology Analysis checkbox.

MXview can do the following two tasks automatically: (1) Create a new topology, and (2) Update the existing

topology.

Creating a new topology deletes all links, requests LLDP information from devices, and draws topology maps

based on the gathered information.

1.
2.

Select View > Auto Topology
Select New Topology
Click OK

' ™

Existing links will be deleted first

1 Update Topology

Existing links will be kept while new links are added

Advanced Topology Analysis
*Additional time is required.

OK ] ’ Cancel
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Topology Management

NOTE

Links drawn manually will be also deleted by this action.

NOTE

Your devices must have firmware version 3.1 or higher to use Advanced Topology Analysis.

NOTE

If the AutoTopology function does not create an accurate representation of the actual network, deselect the

Advanced Topology Analysis check box and try again.

Updating the existing topology adds new links and updates existing links, but does not change the status of

links that are indicated as having been disconnected or links that were drawn manually.

1. Select View 2 Auto Topology
2. Select Update Topology
3. Click OK

i '
& e tron R ==

MNew Topology

Existing links will be deleted first

@ Update Topology

Existing links will be kept while new links are added

[¥] Advanced Topology Analysis
*Additional time is required.

OK ] [ Cancel

The following figure shows an example of a topology map:

-

192168127 31

[ FH] 5
19[2.153.12%.\402 1965 127 12 192168 12T S
PE N, pE
,
LS 5
A, 3
ABE. 127,105 AL 18
;‘L’ pE
=] pE; I
-
|J.
1921681427 06 162168127 114
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MXview Topology Management

Auto topology supports third-party devices which are compatible with LLDP MIB.

Moxa Device* Third-party SNMP Device IP Device
Auto Topology LLDP MIB LLDP MIB Supported if

ARP-based auto topology connected to a

(Moxa switch w/firmware 3.1) Moxa switch.

NOTE LLDP is enabled by default on Moxa devices. Please keep LLDP enabled to use the Auto Topology function.

Redundant Topologies

Redundant topologies have at least one backup link, which will be indicated with a dashed line:

pa pT
P

1?.."{1168.12?.10? 192 63127,
‘a"p? pi2
“'
== 7
’
|'l
5
102 AGEH2T. 100 102 A2 127 105
= e
[ut=] =xy
hagter
19:2.1%.12?.11&7 p§92.1$.12?.1ﬂ4
=3 =}

102 162,127 110

For devices that play a particular role in the topology, MXview will label the devices by displaying the roles
above the images of the devices. Backup links will be indicated with dotted lines.

e RSTP has a Root

e Turbo Ring has a Master

e Turbo Chain has a Head and a Tail

NOTE Only auto topology can draw dashed lines for redundancy links. Manually drawn redundant links will appear as
solid lines.
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PoE Power Consumption Visualization

By periodic polling, a PoE link will display the port number, power (watts), voltage (V), and current (mA)
directly on the topology map.

.Hng 1 I'.'l-lsllr;ﬂ e
i '.'!"-L

o

192.168.129.2 port 4 pd
p AW [ 54V 1 TEmA L\

192 168.129.3 [192.168.129.2p%

VPN Tunnel Visualization

The VPN tunnel link will be indicated using different colored lines, as shown below. An icon in one of three
different colors indicates VPN statuses:

e Blue: All VPN tunnels are connected

VFH WS 254/ SteTesel ——
B —

e Yellow: At least one VPN tunnel is disconnected

Firewwa
VBN 192 188 122 254 / SiteTo Site 1 152 988,122 254 [ stetosite =
e —————— -- -

|
«
'

e Red: All VPN tunnels are disconnected

Fiit ewwal
192188 122254 / SteToSde 182 168,122 254 / selosile \-’PH@

p3
fetetositez 182108127 295

NOTE VPN Tunnel Visualization is only available on Moxa’s EDR-810 series of secure routers.
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PRP/HSR Visualization

MXview is able to indicate different roles of PRP/HSR technology, including PRP, HSR, Coupling, and Quadbox.
The links of PRP/Coupling LAN A, LAN B, and HSR Ring are indicated with different colored lines.

Coupling Coupling

Coupling Port INT oupling
"H PortB  Porta

PortINT port INT

192168127 160127113

68.127.115

192.1688.127.104 192168127103

NOTE PRP/HSR Visualization is only available with Moxa’s PT-G503 series.
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Third-Party Icons

MXview is able to support most network devices, even those made by many different vendors. Below is an
example of a network which includes Moxa devices and a Cisco device. MXview will change the device icon to
indicate that the device is a Cisco device.

- c L0 | 127, 51 T A
Frisil ew Date Lnk iiewalen  Evell Tows W ey
WW Inteeigariud o lad s gt Syl MD}CA
i e e S [ea e 20
- 50 168 127 181 —
i L

—=
i

TITI I LY
ahhhigidiinaaam

o= 1 md v by TS Wi b el M) 1 71 3000

Vendors with MXview support includes: ABB, CISCO, Emerson, Hirschmann, Rockwell, Schneider, and
Siemens.

EFeEEEEE

Port Trunking

Port trunking, also called link aggregation, involves grouping links into a link aggregation group. Trunking links
will be indicated with thick, solid lines.

'll!'..l =1" "

w...;,:... sl M_@w

182168127 2 192,168,127 .1

NOTE Only auto topology can draw thick lines for trunking links. Manually drawn trunking links will appear as solid
lines.

NOTE For trunked link, check “Device Properties” to get the port number corresponding to the trunking group.

foim| Port29  Toonk Gromp 1: Port 25 (Link up) / Port 26 (Link up)
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Add

Use one of the following two options to connect two devices with a link in a topology map:

1. Right click on a device and then select Add Link.
2. Click on a device to select it and then click Link ©> Add Link on the menu bar.

3. Enterthe ports and IP addresses corresponding to the link. Use the plus sign at the left bottom corner to add
multiple entries at one time.

W% Add Link 192 168127 105 @

sonce TR From Port Destination [P Destination Port
192 . 168 . 127 . 105 oo .0 .n
+ 84 ] [ Cancel

NOTE Trunking and redundancy links added manually will appear as solid lines.
NOTE Port numbers must be numeric and entered correctly to obtain the correct traffic information.
NOTE For modular switches, a port number depends on the chassis to which the port belongs, but not on how many

modules are inserted. For switches such as the PT-7828, the first module’s port numbers are from 1 to 8, the
second module’s port humbers are from 9 to 16, and so on. The port humber depends only on which slot the
module is in; in other words, the port number is the same regardless of whether other slots are empty or
occupied.

Delete Link

Use the following steps to remove a link in the topology map:

1. Select the link.
2. Right-click the link and select Delete Link, or select Link - Delete Link.

—m - E_H_E_H_Em__

4 Link Traffi b
102 168.127.44 | Delete Link |
Critital Threshold

NOTE

Deleting a link will delete a link from the topology map, but it will not affect the actual network configuration.
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Delete Device

You can delete devices from the topology map. After a device is deleted, it will be removed from the topology
map and scan range, and the device would not be polled or located when conduction device discovery. Take the
following steps to delete a device:

1. Select the device

2. Right-click the device

3. Select Delete Device

Deleted devices will be recorded in Project & Scan Range.

S

%% Wetwork Scan Range

Scan Range
Add MNetwark

[] Active FirstIP Address Last IP Address Mame
192.168.127.1 192.168.127.250 CED Modify Metwark

Delete Network

Celeted Devices

Recover
Device IP Model Location

192.168.127.100 Deleted Device 1839

Ok and Run Discovery ] Cancel

You may recover devices that have been deleted. Once recovered, the devices will be polled and located when
conducting device discovery Take the following steps to recover deleted devices:

1. Select Project > Scan Range
2. Select a row in table Deleted Devices
3. Click Recover and then click OK

Navigation

Mini map is a frame with a slider for adjusting the resolution. This function helps users zoom in to enlarge
devices or zoom out to view more devices on the screen.

e e
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Background

You may insert a background image into the topology map to provide additional references, such as
geographical information or deployment layout.

Take the following steps to insert or change a background image:

1. Select View > Set Background

2. Choose an image from the local file system.
Take the following steps to delete the background image from the topology map:

Select View > Delete Background

Project Wiew Device Link MNetwork Event Tools Preferences  Help

WViQW etz plaivorns anzigamant Softeice M OXA
4

N A Devices ’ @, Navigation ]

-

Device list I

< >

o

Device Propetties |

T

Recent Event Event Count [l 0 0 0 All Events

[n]} I Source Severity Description Issued Time Lser

Caonfiguring Discovery Range Failed _E4F09:3501 Number of Managed Devices f Max: 01500

Export Topology

The topology map can be exported as a JPEG image. Take the following steps to export the topology map:

1. Select View 2> Export Topology

2. Choose the location to which the image is saved.

OPC Tag Generation

MXview can generate OPC 2.0-compliant tags of device and link properties. OPC clients such as SCADA
Systems can access and use these tags.

1. Select Tools > OPC Server

2. Click Start
33 OPC Server @
Status
Stopped
Start ] [ oK
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Currently, the default information that MXview can prepare as tags includes:

1. A Health tag, which represents the health status of whole network.
2. Device IP address, MAC address, and status, which are labeled beginning with D_.

3. Alink's corresponding IP address and ports, which are labeled beginning with L_.

NOTE The Health tag represents the health status of the entire network. There are three levels: Normal, Warning,
and Critical, with the values 0, 1, and 2 respectively. MXview allows users to use only one tag to monitor the
status of the whole network

MXview can also transfer all the SNMP properties in Device Properties List to OPC tags.

1. Select Tools > Custom OPC Tags

2. Click l;] to manually add properties into list

Select properties in the list and click Register to implement them on devices
4. It shows Tag count and Registered device count

Click OK and finish transferring

&3 Custom OPC Tags | 2|

[ Select Device Properties :
1. Click "+ to add/remove one or more to them.

2 Ifyou cantfind a property of a device, o Find |

Availability -
DslLed1

DslLed2

DslLed3

DsiLed4

DslLeds

IpAddr

IpMask
activeProtocolOfRedundancy
cpuloading300s.0
cpuLoading30s
cpuloading30s.0
cpuloading5s.0

o T o

Activate  Property Name

oK ‘ l Cancel

- Tagcount: 0/512 Registered device count: 0/1024 Register

oK ‘ I Close
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Custom OPC Tags

1. Click +7- to add/remove one or more custom opc

2. Ifyou can'tfind a property of a device, close this dig

Select Devices

All devices

192.168.127 2—-IKS-6728-BPoE
192.168.127 7-AWK-3121

Selected devices

=l

192.168.127 3—-EDS-G516E
192.168.127 4-EDS-G516E
192.168.127 5-EDS-G516E

Activate  Property Name 192.168.127.8~VPort 35-14P 192,168,127 5~EDS-G516E
cpuLoading300s 192.168.127.9-NPar S8000
cpuLoading30s 192.168.127 10~IEX-402-SHDSL
epULoacing5s 192.168.127.11-IEX-402-SHDSL
SevTRangs 192.168.127.12-EDR-210
102.168.127.13-MGate MB3170
memoryUsage 102.168.127.20-ICHP Device
powerConsumption

sfpRxPower. 16
sfpTemperature. 16
sfpTxPower.16
sfpVoltage. 16

[7] Sort by Model [ 0K ] [ Cancel

E Tagcount: 10/512 Registered device count: 11871024

| [ Register ] I

oK ] [ Close |

Custom OPC Tags

1. Click "+~ to add/remove one or more custom opctags. Select one or more tags and click Reqgister to apply devices to them.

2_Ifyou can't find a property of a device, close this dialog and refresh that device.

Activate  Property Name
cpuLoading300s
cpulLoading30s
cpuLoading5s
devTxRange
memaoryUsage
powerConsumption
sfpRxPower. 16
sfpTemperature. 16
sfpTxPower. 16
sfpVoltage. 16

’ + l [ - ”Tag count: 10/512 Registered device count: 118!1024' Register

[ oK ] [ Close

If the properties that you want to transfer are not shown in the properties list, you can use the MXview MIB
Browser to manually import the MIB files. Then, the OID Import Manager can help import the OIDs into
Devices Properties List and they will be easily transferred to OPC tags. In the same way, any third-party
proprietary MIB can generate its OPC tag.
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Example: Retrieving transmission distance though MXview OPC Server

To retrieve transmission distance through MXview OPC Server, the first step is load the relative MIB, and import
the transmission distance SNMP OID “devTxRange” into Device Properties List. Then, users can easily find the
property in the properties list and transfer it to an OPC tag.

1. Select MIB > MIB Browser
2. Select File > Load MIB
3. Select the SNMP MIB and add it into the MIB list

L MIB Browser EI@

Load Wi AgentlP  |127.0.0.1 SNME 1

WIB gen 0.0, v
Unload MIB hIE on

- MIB
Language ' MIE
= POE-MIB Get H Get Mext H Get Subtree H walk H Set

'MIB

Nae/OID Valug

© @ Close

Select MIB 2> OID Import Manager

Click Add and select the specific OID

Assign this OID to selected devices

The new OID appears in the Devices Properties List

The property “devTxRange” is shown in the properties list and can be transferred to an OPC tag

© N o v ok
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@ oD Import Manager
Lizt of Polling OIDs

W ame

Value

ol & s

Show Details

Assign

Add ]

Modify Name ]

’ Delete ]
Close ]
[ Add a New Polling OID ==
File
B awk3121 {1 -
: M
S swMgmt (1) ame

[+ L owerview (1) dew TxFange

Bl | basic (3)

- wireless (5) oD Index

B devTable (1) 1361418601.151151.1.19 1
== devEntry (1)
4% devlndex (1) Operation @) Get
-8 dewChamneld (2) )
%] dewChamnelE (3)
9 devChannells (4) Test ] [ SNMP v
-8 dewChamnelListd (%)
-8, devChannellistEB (6 Mame
@ devChamnelList (7 2l Ivalue
- dewEFtype (3)
-8 dewComntrCode (9 OID Description
-9 dewTErateds (10) VALUE devTxRange OBJEGT-TYPE (
% dewTErateB (1) Syntex: INTEGER (500..11000)
“7? dew THrateG (1) Access: read-nrite
“7? dev THrateBG (13) Status: cument
“7? dewTEpower (14) 3 Description: Transmission distance
-9 deyBeasonlnterval (15)
% deyD TIMinterval (16)
%/ devFragThresh (17) )
.4 ©=1.2.81.418881.15.1.1.5.1.1.19
.
8 ey Trehntenma (21) il
& . -
Add || cancel
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[% Assign Polled Devices

Mame dew TuFlange oD
AL -
List of Devices

192.168.127.1 (192.168.127 1--IC3-G78524-4KF)
192168127 2 (192.168.127 2--TK8-6728-8FE)
192.168.127 .3 (192.168.127 3--EDE-G516E)
192168127 4 (192.168.127 4--EDE-G516E)
192168127 5 (192.168.127 5--EDE-G516E)
192.168.127 6 (192.168.127 6--EDE-G516E)
1921681272 (192.168.127 8--¥Port 36-1MF)
192.168.127 .9 (192.168.127 9--NPort 23000)
192.168.127.10 (192.168.127.10--IEX-402-3HDEL)
192.168.127.11 (192.168.127.11--IEX-402-3HDEL)
192.163.127.12 (192.168.127 12--EDR-810)
192.168.127.13 (192.168.127 13--MGate MB3170)
192.168.127.20 (192.168.127 20--ICMP Device)

[l

136.1418681151151.1.181

Lizt of Belected Devices
1921681277 (192 168 127 7--LAWK-3121)

Canecel

Drevice Properties

ANE-2121-1T3

a2aa

1.9 Build 11101416
00:90:E8:40:49:44

----- W modelMame

----- W =serialbumber

----- W firmware¥ersion
----- W machddress

----- W operationMode ap

----- & enablefutolplonfiz dizable

..... £ Iphddr 192 168 127 .7
..... £ Ipiask 255 255 255 .0
----- 8 defaul tdateway 0.0.0.0

----- % traplerverfdddr

----- W sompTraplommunity alert

----- % trap2lerverdddr
----- O sompTrap2Community alert

m

1921651277

----- 4 dnsferverlpsddr .l 0.0.0.0
----- % dnsferverlpdddr 2 0.0.0.0 5
----- evTxRa - -
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-

Custom OPC Tags @
1. Click "+7-" to addiremove one or f] vices to them.
Select Device Properties @
2. Ifyou cantfind a property of a de
Find |
Activate  Property Name
: cpuLoading300s.0 -
cpuLoading300s ) |
- cpuLoading30s.0
cpuLoading30s )
- cpuLoading5s.0
cpuLoadingss

defaultGateway
memorylsage

- devTxRange
powerConsumption

dnsServerlpAddr

sfpRxPower. 16

dnsServer2lpAddr
sfpTemperature. 16

dns3erverlpAddr.1
sfpTxPower. 16

dnsServerlpAddr.2

FEEEEEEEEE

sfpVoltage. 16

dsIPortName.1
enableAutolpConfig
firmwareVersion

ifDescr.1
OK ] [ Cancel
E Tagcount 91512 Registered device count 117 /1024 Register
oK ] [ Close
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Event and Notification

The following topics are covered in this chapter:

O Monitoring Methods

>
>
>

Qaaoaaaa

>
>
>
>
>
>
>

Monitoring via SNMP Trap Messages
Monitoring via Periodic Polling

Color Coding Indicates Problems

Event Recovery
Severity Level
Custom Events
Recent Events
Event History

Notification

Add an SMS Action

Add an Email Action

Add an SNMP Trap

Add a Mobile Notification
Add a Sound

Add an External Program

Add a Message Box

O Syslog Event
O Network Event Playback

>

>
>
>

Enable Playback Mode
Enter Playback Mode
Time Mode and Event Mode

Overview of Playback User Interface
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Monitoring Methods

Monitoring can be conducted using SNMP trap messages, periodic SNMP polling, periodic ICMP polling, or color

coding, as described in the following subsections.

Monitoring via SNMP Trap Messages

By using the MXview server as a trap destination of a device, events associated with the device will be sent to

the server in real time, and can be seen by remote clients.
Take the following steps to set the trap destination of all devices:

1. Select Tools 2> Set Trap Server to All

2. Enter the IP address of the MXview server and the community string.

"% Set Trap to ALl §|
Server Mumber 1w
IP Address 192 . 168 . 127 . 100

Cammunity String public

Take the following steps to set the trap destination of one device:

1. Select Device> Maintenance-> Configure IP & Trap

2. Choose tab Trap Server
3. Enter the IP address of the MXview server and community string

W 192 168127 122 Config IP and Trap

Easzic TIF‘ Cunﬂguratin/n/v Trap Server l

Ciestination IP1

Community Mame

Destination IF2

Community Marmez2

o< ) (o]

The event types include port link up/down, power on/off, topology change, and configuration change.

Each discovered device will be monitored automatically by trap once its trap destination is configured correctly.
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Monitoring via Periodic Polling

After a device has been discovered, MXview polls the status of the device’s active port periodically. Keep in
mind that since trap messages are transmitted by UDP protocol, there is no absolute guarantee that the
messages will be received. What periodic polling does is provide a higher level of reliability for monitoring
devices.

With periodic polling, MXview can passively monitor the device’s SNMP service, bandwidth utilization, error
packet rate, and collision rate. MXview can also actively monitor device availability through ICMP polling.
MXview pings devices every 10 seconds, and calculates average availability in 24 hours.

Separate thresholds can be used for bandwidth utilization, error packet rate, collision rate, and device
availability, respectively. When any of these thresholds are surpassed, the device will indicate that an event
has occurred.

Color Coding Indicates Problems

When a link causes a warning to be issued or a critical event occurs (link down, for example), the color of the
corresponding link line will change:

192168.127.36 192168.127.34

When a device causes a warning or a critical event occurs (device failure, for example), the errant device will
be indicated with a box with red borders.

In addition, the events will be added to the recent events list.

i) 1 Zowrce Severity Destription Izsued Time Tser
2248 192168127 .36 Critical Port 1 Link Down 2009-11-24 21:36:51
126 19216812734 Critical Port 2 Link Down 2009-11-24 21.36:52

Event Recovery

Events will be recovered automatically when condition that caused the event is resolved.

jin] 1 Source Beverity Description Tzmed Time Tser
225 192.168.127.36 Critical Part 1 Link Down 2009-11-24 21:36:91
228 1892168.127.34 Critical Fort 2 Link Down 2009-11-24 21:36:52
227 192168.127.36 Infarmation FPaort1 Link Down Recovery  2009-11-24 21:38:14
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Severity Level

Events can be set to one of three severity levels: critical, warning, or information. The conditions that give rise
to a particular severity level can be configured by the user. To configure the severity levels, select Project >

Preferences - Events, and then modify the settings.

J Basic Severity Threshold
\;P; User
| Display _
Link Uip Infarmation -
Bl Topotogy |
Bl ippearance Link Down Crical  +
“ Denice Appearance
- | Bandwidth Litlization Over (%) L1} Wamning -
J Advanced 3 ;
f f} I O [”] Bandwidth Utilization Under (%) 0 Waming -
ol
' f,.;' N [ Packet Eror Rate Over (%) o Waming =
2ad J
Lj- SNMP Configuration
{}w [7] Awailability Under(%) 95,00 Waming -
| oK ' Close

Custom Events

By using the MXview Custom Events, users can define their own events with flexible thresholds, severity,
description, and duration.

1. Select Event > Custom Events

2. Click to manually add properties into list

Set the Threshold Type, Threshold humber, Severity, Description, and Duration
Select the properties in the list and click Register to implement them on devices

It shows Tag count and Registered device count

Click OK and finish setting

o v AW
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-

Custom Events @

Click "+/-"to addiremove one or more custom events. Select one more more events and click Register to apply devices to these events.

Activate  EwventMame Threshold Type Threshold Severity Description Duration

i Select Device Properties E

Find || |

DslLed1 -
DslLed2

DslLed3

Dslled4

DslLeds

|pAddr

IpMask
activeProtocolOfRedundancy
cpuLoading300s.0
cpuLoading30s
cpulLoading30s.0
cpuLoading5s.0
defaultGateway

™ L

E Tag count 0/512 o ] I Eaacs ] Register |

[ oK | Close ]

Custom Events E

Click"+7-"to addiremove one or more custom events. Select one more more events and click Register to apply devices to these events.

Activate  Event Mame Threshold Type Threshold Severity Description Duration

cpuLoading300s  [eN [ZLT T I CPU Loading High!

cpuloading30s Mot Equal = Critical = 0
cpuloadingss Mot Equal - Critical v 0
devTxRange MNat Equal - Critical - 0
memoryUsage Mot Equal e Critical = 0
powerConsumption | Mot Equal = Critical = 0
sfpRxPower. 16 Mot Equal - Critical v 0
sfpTemperature.16 | Mot Equal - Critical - 0
sipTxPower. 16 Mot Equal e Critical = 0
=fp\foltage. 16 Mot Equal = Critical = 0

E] Tag count: 10/512  Registered device count: 0 /4096 ’ Register ]

OK | | Close ]
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-

Custom Events

(=]

Click "+~ to addiremove one or more custor| 68 Select Devices

All device Selected devices
Activate  Event Name .Threshold 192 168 127 3-EDS-G516E
cpuLoading300s | Over 192.168.127 2-IKS-6728-8PoE 192.168.127 4-EDS-G516E
cpuloading30s :0ver 192.168.127 7-AWK-3121 192.168.127.5-EDS-G516E
cpuLoading5s | Over 192.168.127 8-VPort 36-1MP 192.168.127.6-EDS-G516E
devTxRange :Elelow 192.168.127.9-NPort 58000
memoryUsage Over 192.168.127.10-|EX-402-SHDSL
—F 192.168.127.11-|EX-402-SHDSL
powerConsumption I

192.168.127.12-EDR-810
192.168.127 13-MGate MB3170
192.168.127 20—-ICMP Device

sfpRxPower. 16
sfpTemperature. 16
sfpTxPower. 16
sfpVoltage. 16

[ Sort by Model ’ oK

J {

Cancel

E Tagcount 10/512  Registered device count: 0/4096 Register

I

OK Close

J {

While the events are triggered, they will be shown in the Recent Events List and the related devices will be

marked in color.

| Root

Tl
192 163,17 @ _-——-"‘—-“
2 B
192180127 &
192 151275

[
1921681270

-

Pl

192.168.127.11 192,160,127 .10

Taz 18312712

192163127 12

192,183,127 7

m

All Events

Recent Events :Unacked Last Fifty Events = 107 o] | 334

Ack \D' ! Source Source IP Device Alias Severity Description Time Issued

[0 435 WXvewSever 1921681276  192.168.127.5-EDS-GE16E Warning g‘:‘iz‘:;izx:gﬁ:ﬁig‘;d TCEm=T 2014-06-19 14:35:51
[ 434 MXview Server 192.168.127.5 192.168.127.5-EDS-G516E Information Port & Link Up 2014-06-19 14:35:29
[ 433 IMXview Server 192.168.127.6 192.168.127.6-EDS-G516E Information Port 7 Link Up 2014-06-19 14:35:27
[0 432  Trap 192.168.127.5 192.168.127.5-EDS-G516E Warning LLDP table has changed 2014-06-19 14:35:26
[ 431 Trap 192.168.127.3 192.168.127.3—ED5-G516E Information Turbo Ring Topology has changed 2014-06-19 14:35:26
[ 430 Trap 192.168.127.6 192.168.127.6—-EDS-G516E Information  Turbo Ring Tepolegy has changed 2014-06-19 14:35:26
[ 429 Trap 192.168.127.6 192.168.127.6-ED5-G516E ‘Warning LLDP table has changed 2014-06-19 14:35:26
[0 428 Trap 192.168.127.5 192.168.127.5-EDS-G516E Information Port & Link Up 2014-06-19 14:35:25 _

9-6




MXview

Event and Notification

Once the triggered properties are back to normal status, MXview will show recovery events in the Recent

Events List.

RecentEvents | AckAll | [Unssked LostFiftyEvents v 120 225 | | All Events J
Ack 1D Source Source IP Device Alias Severity Description Time Issued
Loading5s i d: Threshold = 10, value = -
] 435 MXviewSever  192168127.6  192.168.127 5—EDS-G516E Information TP~ -0A¢INGDS 1S recovered: Thresho NALEE 5014-06-19 14:36:48
CPU Loading Recovery!
cpuloading5s: Threshold = 10, value = 19
435 MDMiew S 192168127.6  192.168.127 6~EDS-GS16E Wi 2014-06-19 14:35:51
o Anew Server MG ~py | pading High in 53
] 434  MviewServer 1921681275  192.168.127 5-EDS-G516E Information Port  Link Up 2014-06-19 14:35:29
[] 433  WviewSever  192168427.6  192.168.127 6—EDS-GS16E Information Port 7 Link Up 2014-06-19 14:35:27 | =
] 432 Trap 192168.127.5  192.168.127.5-EDS-GS16E Warning  LLDP table has changed 2014-06-19 14:35:26
O 431 Trap 192168.127.3  192.168.127.3-EDS-GS16E Information Turbo Ring Topology has changed 2014-06-19 14:35:26
[ 430 Trap 192.168.127.6 192.168.127 6—-EDS-G516E Information Turbo Ring Topology has changed 2014-06-19 14:35:26

NOTE

The unit of duration is minutes, and only integer values can be set.

Recent Events

MXview shows recent events at the bottom of the Dashboard.

Recent Events Ack All Tnacked Last Fifty Events - 28 31 | \ All Events
Ack IEi ! Source Source IP Device Alias Severity Description Time Issued

[F] 66 Trap 1921681278 182.168.127 6—... Information Turbo Ring Topology has changed 2014-08-19 09:26:21 o
[F] 85 Trap 192.168.1275 192.168.127 5—.. Warning LLDP table has changed 2014-08-19 09:26:21

[ 64 Trap 192.168.1275 192.168.127 5—_. Information Port 8 Link Up 2014-06-19 09:26:20

[ 63 Trap 192.168.127 6 192.168.127 6—... Information Port 7 Link Up 2014-06-19 09:26:20

[ 62 Trap 192.168.127 6 192.168.127.6—... Critical Port 7 Link Down 2014-06-19 09:26:19

[ 81 Trap 192.168.1275 192.168.127.5—... Critical Port 8 Link Down 2014-06-19 09:26:19 L
[F] 60 Trap 192.168.1275 192.168.127 5—_. Information Port 8 Link Up 2014-06-19 09:26:19 3
[F] 59 Trap 192.168.127.6 192.168.127.6—... Information  Port 7 Link Up 2014-06-19 09:26:19

[ 58 Trap 192.168.127.3 182.168.127 3—... Information Turbo Ring Topology has changed 2014-06-19 09:26:18 IR
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Event History

To show the event history of all devices, select Event - All from the menu bar.

To show the event history of a single device, right click the device and select Events.

W% ANl Events E

Filter Conditions

Source Ay hd Ack | Any hd From | |00 % |:/00 % To w23 % ;|59 ¥
Ack D Source Source P Severity Description Time Issued

O 19 Mxview Server 192168127106 Critical Device ICMP unreachahle 2011-12-2615:26:11 ~

O 20 Mxview Server 192168127113 Critical Device ICMP unreachahle 2011-12-2615:26:11

O 21 Wxiew Server 192168127111 Critical Dievice ICMP unreachable 2011-12-26 15:26:11

O a2 Wixiew Server 192168127109 Critical Dievice ICMP unreachable 2011-12-26 15:26:11

O a3 Wxiew Server 192168127110 Critical Dievice ICMP unreachable 2011-12-26 15:26:11

O 24 Mxiew Server 192168127236  Wamning Dievice SHNMP unreachable 2011-12-26 15:26:13

O a5 Wixiew Server 192 168127112 Critical Cevice ICMP unreachable 2011-12-26 15:26:13

O 26 Wixiew Server 192 168127 150 Critical Cevice ICMP unreachable 2011-12-26 15:26:13

O v Miiew Server 192 168127 67 Critical Device ICMP unreachable 2011-12-26 15:26:13

O 28 Miiew Server 192 168127 .91 Critical Device ICMP unreachable 2011-12-26 15:26:13

| 29 Miiew Server 192 168127 162 Critical Device ICMP unreachable 2011-12-26 15:26:13

| 30 Miiew Server 192168127200 Critical Device ICMP unreachable 2011-12-26 15:26:13

| 31 Miiew Server 192168127103 Critical Device ICMP unreachable 2011-12-26 15:26:14

| 32 Myview Server 192168127102 Critical Device ICMP unreachable 2011-12-26 15:26:15

| 33 Myview Server 192168127 237 Critical Device ICMP unreachable 2011-12-26 15:26:15

O 34 Myview Server 192 168.127.235 Critical Device ICMP unreachable 2011-12-26 15:26:15

1 35 Myview Server 192168127250 Critical Device ICMP unreachable 2011-12-26 15:26:15

1 36 Myview Server 192168127253 Critical Device ICMP unreachable 2011-12-26 15:26:15

O a7 Myview Server  192168.127.252 Warning Device SMMP unreachable 2011-12-26 15:26:16

O 38 Myview Server 192168127254 Infarmation Device ICMP reachahle 2011-12-26 15:26:16

(| 39 Miview Server  192168.127.236 Information Device ICMP reachable 2011-12-26 15:26:16

(| 40 Miview Server 192168127182 Information Device ICMP reachable 2011-12-26 15:26:16

[ 41 Miview Server 192168127183 Information Device ICMP reachable 2011-12-26 15:26:16

[ 42 Mxview Server 192168127181 Information Device ICMP reachable 2011-12-26 15:26:16

(| 43 Miview Server  192.168.127.252 Information Device ICMP reachable 2011-12-26 15:26:16

(| 44 Mxview Server 1921681271 Information Device ICMP reachable 2011-12-26 15:26:17

(| 45 hxview Server 19216812712 Information Device ICMP reachable 2011-12-2615:26:117
[ First Page ] [ Previous Page ] [ Mext Page ] [ Last Page ] 1/1 [ Export to CS% ] [ Clear &l ] [ Close ]

The table contains 40 entries on a page. Use the page controls at the bottom to navigate between pages.

First Page ][ Previous Page ][ Mext Page ” Last Page 11

You can sort the table by clicking the header cells.
Time iszued L
To filter the table, use the selection box of the header cell and select a value.

Filter Conditions

Source ARy b Ack Ay b’ From w Qo w00 v | To w23 v [1[59 v

NOTE The sorting and filtering functions only affect table entries currently showing on the screen. They do not
regenerate the entire table. This remains true even if there are currently fewer than 40 entries showing.

You can export all events to a CSV file, or delete all events from the database.

Export to CSY ” Clear &l
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Notification

You can associate an action, such as send a text message, send an email, make a sound, or run an external
program, with a combination of a type of event, a source IP address, and a severity level.

There are 7 actions:

SMS - send a SMS text message
Email - send an email

Program - run an external program
Sound - make a sound

Message Box - show a message box

SNMP Trap - send a SNMP trap to other SNMP trap server

Mobile Client - send a push notification to mobile devices

P

L Actions

Mame

Type |SMS -
Phone Mumber (EMail
Program
Sound
Message Box

SMMP Trap
Maobile Client

There are 19 event types:

ICMP unreachable

SNMP unreachable

Power off

Power on

Link down

Power change to DC

Power change to AC

Input Bandwidth Utilization over Threshold
Input Bandwidth Utilization under Threshold
Output Bandwidth Utilization over Threshold
Output Bandwidth Utilization under Threshold
Input Packet Error Rate over Threshold
Output Packet Error Rate over Threshold
Device availability under Threshold

A custom event is triggered

A custom event is recovered

Secure router under DDoS attack

Secure router firewall under attack

Secure router trust access under attack
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I Motification @

Motification
Maotification Name
Event Type 'Se cure router trust access under attack - ]
ICMP unreachable o
LR SMMP unreachable
Power off 3
Power an B
Action Link down

Power change to DC
Power change to AC
Input Bandwidth Uitilization over Threshold -

oK Cancel

Add an SMS Action

To send an SMS notification, first connect an SMS modem, such as the Moxa Oncell, to an MXview Server COM
port. Take the following steps to configure SMS notification:

1. Select Event 2 Notification.

Motification @

Action List

Mame Type Contact/Program / File Mew
Modify

Delate

Motification List

Mame Type Source Component Actions New

Delete

Maotification Seftings 0K
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2. Click Notification Settings.

@& Motification Settings @

| EMail | SME | SHMP Trap | Mobile Clisnt
SMS COM Port Setup

COM Port coma
Baud Rate 115200 -
Mode TEXT Mode -

OK ] ’ Cancel

3. Turn to SMS page. Select the COM port, Baud Rate, and Mode to which the modem is connected, and then
click OK.

4. Click New in the Action List.

Select SMS as the type, type the phone number, give the action a name, and then click OK.

-

Actions @

Mame Admin M3
Type  SMS -]

Phone Mumber 0920123456

I OK ] I Cancel ]

6. Click New in the Notification List.
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7. Select the action just added and the corresponding event type, source IP.

Motification @
Muotification
Motification Mame
Event Type .ICMF' unreachable -
Source @ P () Group
Action [T] Admin SMS
8. Click OK.
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Add an Email Action

Take the following steps to configure the Email (SMTP) server to send an Email notification:

1. Select Event > Notification.

2. Click Notification Settings.

Motification Settings @

EMail | 5MS | SWMP Trap | Mobile Clisnt
EMail Server Setup

Domain Name / IP

Port Mumber 25

Encryption Mone A
User Mame

Passwaord

Sender Address

Ok I [ Cancel

3. Turn to Email page. Input the SMTP server that can send an e-mail and the user name and password needed
to log in to the server, and then click OK.

4. Click New in the Action List.

Select Email as the type, type the email address, give the action a name, and then click OK.

Actions @

-

Mame Admin Email
Type SM3 -

Phone Mumber admin@your.com

| oK || Cancel |

6. Click New in the Notification List.
7. Select the action just added and the corresponding event type, source IP.
8. Click OK.
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Add an SNMP Trap

MXview can collaborate with other network management software, and send SNMP Traps to third-party NMSes.
MXview supports up to two trap servers. Take the following steps to add an SNMP Trap:

1. Select Event 2> Notification.
2. Click Notification Settings.

Maotification Settings @

SNMP Trep | Mobile Client

SMMP Trap

SMMP Version SMMP Version 1 -

Community Mame 1

Trap Server 1

Community Mame 2

Trap Senver 2

Ok ‘ I Cancel

Click the SNMP Trap tab. Enter the SNMP version and trap server information, and then click OK.

4. Click New in the Action List.
Select SNMP Trap as the Type, give the action a name, and then click OK.

Actions @

-

Mame M¥view Trap

Type SMMP Trap -

| o

l Cancel ‘

6. Click New in the Notification List.

7. Select the action just added and the corresponding event type, source IP.

8. Click OK.
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Add a Mobile Notification

MXview can send mobile notifications through Apple APNS or Google C2DM with Moxa’s mobile
APP MXview ToGo.

Select Event 2> Notification.

Click New in Action List.

When the Actions window opens, type in a Name and select Mobile Client as the type.
Click Receiver to select an Email as identification.

Click OK.
&3 Actions @

Mame Admin Mobile

uoA N

-

Type | Mobile Client -
Email |admin@your.com Receiver
| Ok | | Cancel |

Active Mobile Users
admin@your.com

]9 | | Cancel

6. Click New in Notification List.

7. Type in a Notification Name, select Event Type, enter Source IP, and click the Actions.

8. Click OK.

NOTE This function should be used with Moxa’s mobile APP MXview ToGo. After setting an Email as identification in
MXview ToGo and connecting to MXview Server, you will be able to find the Email in the Receiver list.
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NOTE

Using Mobile Notification should give MXview server the capability to connect to Apple APNS or Google C2DM.
Please allow the following outgoing ports in your firewall policies:

e Google: 5228, 5229, and 5230

o Apple: 443, 2194, 2195, and 5223

NOTE Use the following commands to review communication between MXview server and Apple APNS or Google
C2DM:
e telnet gcm.googleapis.com 5228
e telnet gateway.sandbox.push.apple.com 443

NOTE The Apple APNS certificate should be renewed annually. Please check Moxa’s website for latest APNS

certificate.

Add a Sound

When a sound notification is triggered, the MXview server will play the associated sound file. The sound will
play repeatedly until some stops it manually. Take the following steps to add a sound:

1. Select Event 2> Notification.

2. Click New in Action List.

3. Select Sound as the type, select a file from the local computer, give the action a name, and then click OK.
The file will be uploaded to the MXview server.

ri.'l‘ﬁ Actions @

-

Mame Admin Sound

Type Sound -
Sound beep.way Diirectary
Ok | | Cancel

4. Click New in the Notification List.
5. Select the action just added and the corresponding event type, source IP.
6. Click OK.

When an associated event occurs, the sound file will be played and a window will pop up:

I !

Warning @

i Stop playing the sound

| 0] 4 | | Cancel |

The sound will not stop until someone clicks OK.
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NOTE When more than one event occurs, the sound file corresponding to the first event will be played first, and the
sounds corresponding to subsequent events will be queued. After first sound is stopped, the next sound in the

queue will be played.

NOTE Only the wav format is supported.

Add an External Program

When a program notification is triggered, the MXview server will execute the associated program. Take the

following steps to add a program:

1.
2.
3.

6.

Select Event 2> Notification.

Click New in the Action List.

Select Program as the type, select a file from the local computer, give the action a name, and then click OK.
The file will be uploaded to the MXview server.

Click New in the Notification List.

Select the action just added, the corresponding event type, and the source IP.

Click OK.

When an associated event occurs, the program file will be executed.

Add a Message Box

When a message box notification is triggered, the MXview server will display the message box. You can create

a new message box by following the steps below:

1
2
3
4,
5
6

Select Event > Notification.

Click New in the Action List.

Select Message Box as the type, give the action a name, and then click OK.
Click New in the Notification List.

Select the action just added, the corresponding event type, and the source IP.
Click OK.

When an associated event occurs, the system will show the message box.
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Syslog Event

MXview can act as a Syslog Event Server with Syslog Event Viewer. Take the following steps to use the viewer
to check all syslog events:

1. Select Event > Syslog Event Viewer
2. Enter Filter Conditions
3. Click Query

Syslog Event Viewer @I

Filter Conditions
Facility | Any ~| From ~ o0 ~| o0 v| Ta - |23 ~| 58 ~
Priority Higher than or equals to ] .Debug = 1P 192 a2 . 127 . 3 ’ Reset ]
Message | ’ Query ]

Time Stamp IP Priarity Facility Message

2015-01-08 1412:21 192 188127 3 Warning local5 Jan 01 00:47:00 192 168.127.3 INFO:Configuration change activated

2015-01-08 14:12:36 192 168.127.3 Warning locals Jan 01 00:47:14 192.168.127.3 INFO:Power 1 transition (Off -= On)

2015-01-08 1412:41 192.168.127.3 Warning locals Jan 01 00:47:19 192.168.127.3 INFO:Power 1 transition (On -= Off)

2015-01-08 14:12:45 192.168.127.3 Warning locals Jan 01 00:47:23 192.168.127.3 INFO:Power 1 transition (Off -= On)

2015-01-08 14:12:58 192.168.127.3 Warning locals Jan 01 00:47:37 192.168.127 .3 INFO:Configuration change activated

2015-01-08 14:13:13 192.168.127.3 Warning locals Jan 01 00:47:51 192.168.127.3 INFO:Power 1 transition (On -= Off)

2015-01-08 14:13:30 192.168.127.3 Informational locals Jan 01 00:00:03 192.168.127.3 INFO:Cold start

2015-01-08 14:13:30 192.168.127.3 Informational locals Jan 01 00:00:08 192.168.127.3 INFO:Port 3 link on

2015-01-08 14:13:30 192.168.127.3 Informational locals Jan 01 00:00:08 192.168.127_.3 INFO:Port 3 link off

2015-01-08 14:13:30 192.168.127.3 Informational locals Jan 01 00:00:08 192.168.127.3 INFO:Port 3 link on

2015-01-08 14:13:30 192.168.127.3 Warning locals Jan 01 00:00:08 192.168.127.3 INFO:Power 1 transition (Off -= On)

2015-01-08 14:14:04 192.168.127.3 Warning locals Jan 01 00:00:44 192.168.127.3 INFO:Power 2 transition (On -= Off)

2015-01-08 14:14:05 192.168.127.3 Warning locals Jan 01 00:00:42 192.168.127.3 INFO:Power 2 transition (Off -= On)

2015-01-08 141415 192.168.127.3 Warning locals Jan 01 00:00:52 192.168.127 3 INFO:Power 1 transition (On -= Off)

2015-01-08 141416 192 168.127.3 Warning locals Jan 01 00:00:53 192.168.127.3 INFO:Power 1 transition (Off -= On)

2015-01-08 14:14:17 192.168.127.3 Warning locals Jan 01 00:00:54 192.168.127.3 INFO:Power 1 transition (On -= Off)

2015-01-08 14:14:18 192.168.127.3 Warning locals Jan 01 00:00:55 192.168.127.3 INFO:Power 1 transition (Off -= On)

2015-01-08 14:14:19 192.168.127.3 Warning locals Jan 01 00:00:56 192.168.127.3 INFO:Power 1 transition (On - Off)

2015-01-08 14:14:20 192.168.127.3 Warning locals Jan 01 00:00:57 192.168.127.3 INFO:Power 1 transition (Off -= On)

First Page ] [ Previous Page ] [ Next Page ] [ Last Page 111 Export to CSWV ] [ Clear Al ] [ Close

Network Event Playback

Whenever MXview detects that a device under its management is experiencing an event, such as link down,
MXview will update the device status in the topology map. Moreover, MXview will keep records of status
changes in a database for up to 30 days, and provides an interface that allows users to go back and check
network status from any time within 30 days in a visualized way.
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Enable Playback Mode

The playback mode is disabled by default. To enable it:

1. Select Project > Preferences

2. Click System Configuration, choose Enable for Playback

W% Preferences

,0 Basic System Configuration

@ Display

Background Discovery
_____ Bl Topoiogy

Threshald of Disk Space [ o] Me (Marm is disabled it setto 0)
----- Bl sppearance

----- Bl pevice Panel

@ Advanced

Flayhack Enable A
=ywhen "Playback function is enablgCisable d status of devices and links while an e
vent happened, and you can enter pMo watch detail process.

* Additional disk space is reguired when "Playback" function is enahled.

onfiguration

: :*,} SNMP Configuration

: _:J} Events

( oK | [ Close

Enter Playback Mode

To enter the playback mode, choose Playback as operation mode at the index page.

Industrial Network Management Software

Username

Password

rks.

s . ' . Operation Mode

Monitor il
Monitor

Playback
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Time Mode and Event Mode

There are two event playback modes. In time mode, MXview will replay the event on the topology map on a

second-to-second basis. In event mode, MXview will replay event by event. Users can select playback speeds

from 1X to 16X.

Overview of Playback User Interface

Event Playback

SRoot )

MOXA

I Logout 9

102 82127,

192188 (127 105

|\

192 468 127 150

]

192168127110

[»]

- v

2011-12-26 15:34:23

00:00 02:00 04:00 06:00 08:00 10:00 12:00 14:00 16:00 18:00 20:00 22:00 24:00

0

— — 13 —_—
- 0> @
Event Made | w
R ———

q

192.1..
1921
192.1..
1921
192.1..

... Device SMMP reachable  2011-1..
... Device ICMP reachable 2011-1...
... Device ICMP reachable  2011-1..
... Device ICMP reachable 2011-1...

2011-1..

e Topology map

The topology map displays the network status at the time indicated in the time indicator.
e Event List and All Event button
The events surrounding the current displayed event are displayed in this window. The most recent event is
highlighted. Click All Events to access an all events search box, with filters. In the filtered results, you can

click on a filtered event to jump straight to that event in the playback.

e Control pane

The control pane includes a time indicator, time slider, and calendar, which correspond to the network
currently displayed on the topology map.

Users can slide to the time point they would like to check. The slider covers 24 hours in the selected date. To
change the date, users can click on the calendar and choose a different date.
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Traffic Reporting

MXview compiles traffic statistics for devices running on the network. The statistics are used to create reports
that show trend utilization and performance of the device interfaces. Statistics are complied for the following

items:

e Traffic utilization (%)

e Error packet rate (%)

Events will be generated when one of these items is above or below the corresponding thresholds.

Checking the Trend

Before MXview can collect traffic statistics between two devices, a link must be created (see the section “Adding
a Link” in chapter 8 to see how to add a link).
Right-click on a link, then choose Link Traffic, and choose either Port Traffic or Packet Error Rate

monitoring mode.

Link Traffic 3 Part Traffic
Delete Link Packet Error Rate
Severity Threshold

In Port Traffic mode, the graph shows the utilization percentage by a specific time period. You can define your
time period at the window’s top right corner. The minimum interval is one day.

# Link Utilization x|

Utilization 2012-06-05 To 2012-06-06 s

Fom 192.168.127.12 Port7 To 192.168.127.37 Portl
From 192.168.127.37 Portl To 192.168.127.12 Port7 © Fom [m5202 7] 1o [EYENE -]

0.0100
&
50,0075
w
o
=
|1 | __J___L__
0.0050
| . .
| | | | ‘"'I_
0.0025
06-Jun 00:00 08-Jun 12:00

Default Size Export Graph | Export Data 0K




MXview Traffic Reporting

The Y-axis scale (percentage) is adjustable, and is accurate to 4 decimal points. To change the Y-axis scale, you
just need to roll your mouse wheel down or up. No matter what scale you change it to, you can press the
Default Size to restore graph scale back to the original setting.

The data shown here can be exported. At the bottom of the window, you can export the graph as a PNG file or
export the data as a CSV file.

The interface for Packet Error Rate and Port traffic monitoring is identical.

Threshold & Event Notification

The traffic conditions below can trigger events:

1. Bandwidth utilization is over a threshold.
2. Bandwidth utilization is under a threshold.

3. Packet error rate is over a threshold.

Since a link is bidirectional, the event will be triggered when one of the directions satisfies any event’s trigger
condition.

To learn how to change the threshold, refer to Monitoring Methods = Color Coding Indicates Problems >
Severity Level in Chapter 9.

To learn how to configure notification, refer to Monitoring Methods - Color Coding Indicates Problems >
Notification in Chapter 9.
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Device Management

The following topics are covered in this chapter.

Device Properties

Device Virtual Panel

Changing Device Properties

Assign Icon

Web Console Login

Management Interface

Configuration Backup and Restoration (Moxa devices only)
Firmware upgrade

Refresh Status

Qaoaaoaogoaogoooogaa

Mass Operation Configuration Export/Import and Firmware Upgrade
» Export Configurations from Multiple Devices

» Import a Configuration to Multiple Devices

» Upgrade Firmware on Multiple Devices

» Scheduled Configuration Export/Import

» Configuration Change History and Comparison

O Device and Inventory Report
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Device Properties

MXview provides three ways to view device properties.

1.

Device Property box in main window
(see the Device Property List section in chapter 4)

Fast Device Property

Right click on a device in the main screen and click property.

You may select a device and right click on it. Properties that are listed include model name, MAC address,
IP address, Netmask, gateway, port type and status, power status, redundancy protocol, SNMP, and ICMP
availability.

Customizable Device Property

In the menu bar, select Information->Device Property

Device property provides a highly customizable table to view the device properties in your network. On
the top of the window, editable optional items include IP, Alias, Property and Value.

By selecting the drop-down menu on each option item, you can filter specific items which you wish to
display.

The property item has the same property as an inventory report (Refer to the section Inventory Report
in Chapter 11). As a result, you can use device property to filter out the specific property you want to see.

%= Device Froperties m

IP * | Aliaz + | Property * | Value -
19216812712 Matt's Switch #2 power! InputStatus an
19216812727 Matt's Switch #1 power! InputStatus on
192168.127.61 192168.127.61 EDS-4... power! InputStatus an
192 168.127.62 1921683127.62 EDS-4... power! InputStatus an
192168127154 192 168127 155 EDS-... power! InputStatus an
192168127156 192168127 156 EDS-... power! InputStatus an
192 168.127.2450 192168127 240 EDS-... power! InputStatus aff
192168127 241 192 168.127.241 EDS-... power! InputStatus aff
192.168.129.2 192.168.129.2 EDS-Fa... power! InputStatus an
192.168.129.4 192 168.1259 4 EDS-GaA.. power! InputStatus aff
192.168.129.5 192 168.1259.49 EDS-Ga.. power! InputStatus aff
192.168.129.3 192 168.125.8 EDS-40... power! InputStatus aff
Export to C5Y Close

The Device Property window is able to export to a CSV file. To do this, simply click the Export to CSV button.
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Device Virtual Panel

MXview can show the front panel of Moxa switches, and indicate the active status of ports and LED indicators:

Right click on a device and select Panel

/4 192.168.127.105 -

Pl O

=
Ethernet Port 8
100TH RJ45.

T i

w
LJ
=
-
w
=]
=
o
E
L

=

EDS-40EA

Changing Device Properties

Take the following steps to change a device’s location, name, contact, IP, netmask, gateway, trap server, and

SNMP configuration:

1. Select a device.
2. Select Device > Maintenance > Configure IP & Trap.

Click the Basic tab to change the name, location, and contact information for a device. The new values will be

written to the device’s firmware.

Click the IP Configuration tab to change a device’s IP address, netmask, gateway, DNS server, and method
of obtaining the IP.

Click the Trap Server tab to change IP addresses and community strings of trap servers. Moxa switches can
send trap messages to at most 2 trap servers.
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#1092 168127122 Config IP and Trap

Basiv” IP Configurstion | Trap Server

IP Address .o les 127 . 133
Metmask 355 . @8s . 355 0 0
Gateway 0 : I} : 1] , 1]
DNELIP o . o . 0o . 0
DNE2 TP o . o . 0o . a0

At TP Disahled_v|

[ox ] [omel ]

Assign Icon

MXview allows users to change the device icon manually. Follow the steps below to select a device icon from
within MXview’s icon database.

1. Select a device.
2. Select Device >Maintenance > Assign model.

You will see the Assign Model window pop up. Select a switch model from the drop-down list, and click the
Assign button to confirm your selection.

|
S . ==

P 192.165.127.4

Model EDE-4084

Assign to model

[CHE Device -~
ST Device —

MO L Device
Fockwell -
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Web Console Login

To log in to the device’s web console, select Device - console.

NOTE For IE6, MXview will open the console in the window of the MXview Client.

Management Interface

1. Navigate to Project = Preferences - Management Interface.

2. The Web console protocol can be set to HTTP or HTTPS, and then the port numbers of the HTTP and HTTPS
can be set by users. In addition, the Telnet port can be set as well.

L4 Preferences @

i@ User Management Interface

----- 2'}} Account Management

..... 2'}3 Password Policy

3 Web console protocal HITP
----- 2:}} Login Motification e T
) Display HTTP Port 80
----- [ 7 Topology
= HTTPS Port 443
----- k_- Appearance
Telnet Port 23

----- k_. Device Appearance

----- k_- Security View
) Advanced

Vg
----- -t 2 System Configuration
o

=t

----- ‘0 5 Device
=re
----- (0 3 SMNMP Configuration

=t

----- (0 2 Events

=t

----- J(FJ1anagement Interface
i

«

oK | | Close

Configuration Backup and Restoration (Moxa
devices only)

Take the following steps to back up a device’s configuration file to a local computer:

1. Select Device > Maintenance > Configuration > Load from Device.

2. Choose the location where you would like to save the file.
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Take the following steps to restore a device’s configuration file:

1. Select Device > Configuration > Load to Device.

% Load to Device 192 168 127 237

From File | I Browse ]

ok ] [omea ]

2. Choose the file and click OK.

Firmware upgrade

To up upgrade a device's firmware, select Device > Firmware Upgrade. The firmware will be uploaded to
and installed on the device.

Diowmnloading the Fionware File,the operation may take several mintes Do not tum the power off or disconnect the network Please wait a moment!

NOTE After the firmware has been installed successfully, the device will restart. This action could take a few seconds.

Refresh Status

Since some device data is collected by polling, there may be a time delay for some data. To refresh a device to
get its updated status, select Device - Refresh.

Mass Operation Configuration Export/Import
and Firmware Upgrade

MXview lets users export/import configuration and upgrade firmware in a mass deployment to a group of
devices.
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Export Configurations from Multiple Devices

1. Select Tools > Configuration Center

®% Confignration Center

V| MAC

List of Devices

192.168.127.1 -- PT-7328 ~
192.168.127.5 -- SNMP Device
192.168.127.12 -- EDR-4034
192.168.127 27 -- EDE-4034
192.168.127 34 -- EDR-4034
102.168.127 67 -- ICHMP Device
192.168.127.83 -- EDR-5134
102.168.127 91 -- ICMP Device
192.168.127.102 - ICMF Device
192.168.127.103 - ICMF Device
192.168.127.104 - ED3-4084
192.168.127.105 - ED3-4084
192.168.127.106 - ED3-4084
192.168.127.107 - ED3-4084
192.168.127.109 - ED3-4084
192.168.127.110 - EDS-4084
192.168.127.111 - EDS-4084
192.168.127.112 - ED3-4084
192.168.127.115 - ED3-4084
192.168.127.150 - AWK-4121
102.168.127.162 - EDS-4084
192.168.127.181 - ICMF Device
192.168.127.182 - ICMF Device
192.168.127.183 - ICMF Device
192.168.127 200 - SNMP Device
192.168.127 235 - EDS-G509
192.168.127 236 - EDS-G509

AN 1SN 1A A9 TR CAn

Location

List of Configurations

Filename

Expart fram Device l l Impartto Device l

X

Creating Time Last Checking Time

Close

2. Click Export from Device

3. Select a folder in which to store configuration files

4. Select devices to export configuration files from and add them to the list. Click Export

®% Export Configuration &|
IP Lddress Statuz

192,168,127 34 Snccess L
192.168.127.87 Exporting...
192,168,127 88 Waiting...
102.168.127.91 TWaiting...
102.168.127.102 TWaiting...
102.168.127.10% TWaiting...
102.168.127.104 TWaiting...
102.168.127.105 TWaiting...
102.168.127.106 TWaiting...
102.168.127.107 TWaiting...
102.168.127.109 TWaiting...
192.168.127.110 TWaiting...
192.168.127.111 TWaiting...
192.168.127.112 TWaiting...

192168127 113 Waiting. ..

192.168.127 150 Waiting. ..

192168127 162 Waiting... w

After a few seconds, the configuration files will be exported to the designated folder, with IP addresses and

timestamps in the filenames.
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Import a Configuration to Multiple Devices

Moxa switches can import a segment of a configuration file and change device configurations based on the
parameters the segment describes. MXview helps users import a segment of a configuration file to multiple

devices.

1. Select Tools > Configuration Center

2. Click Import to Device

3. Select a configuration file segment

4. Select devices to import configuration files to and add them to the list. Click Import

After a few seconds, the configuration file segment will be imported to devices and activated.

Upgrade Firmware on Multiple Devices

1
2
3.
4

Select Information 2 Firmware Version
Click Upgrade
Select a firmware file

Select devices that upgrade firmware and add to the list. Click Upgrade

The firmware will be upgraded to devices one by one. MXview will wait for 30 seconds before upgrading the
next device on the list, in order to give the upgrading devices sufficient time to finish the process.

Scheduled Configuration Export/Import

1. Select Tools > Job Scheduler
= B
Listof Joh Infarmation of Job
Name of Joh:
Action of Job:
Frequency of Joh:
Description of Job:
Add Close
2. Click Add.
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3. Enter a job name and select Import Configuration, Export Configuration or Database Backup in the

drop-down box.

= X

Step 1 - Job Information | Step 2 - Select Devices | Step 3 - Schedule Time

Narme of Jok daily_sxpor
Action of Job Export Configuratian A

Description of Job

Mext ] l Cancel

4. Select the devices that apply and add them to the list. Click Next

5. Select the execution routine.

Configuration Change History and Comparison

When MXview exports configurations from devices, whether manually or by schedule, MXview will compare the
exported configuration with the last configuration exported and stored on the MXview server. If there is any
difference MXview will save the configuration on the MXview server. Users can then check the change history

of the configuration file:

1. Select Tools > Configuration Center

2. Check List of Configurations
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Select Tools > Configuration Center
Click Compare
Select two IP addresses and their configurations

Change | 465 Delete 1877 Insert 1]

B_192168.127.88_20111226_1731.ini

And users can compare any 2 stored configurations at MXview server

S_1892168.127.34_20111226_1730.ini

1. [EtherDevice Server Configuration File] 1. [EtherDevice Server Configuration File] o’
2 2

3 # Model MName 3 # Model MName

4 4

5: MadelName EDS-518A-55-5C 5: MadelName EDS-408A

B B

T T

a a

9 9

10 10

11: # System |dentification # 11: # System |dentification #

12 12

13 13

14 14

15: # [SwitchMarme]: Switch MName 15: # [SwitchMarme]: Switch MName

16: 16:

17 % --= max. length = 30 words 17 % --= max. length = 30 words

18 18

18: SwitchMame Managed Redundant Switch 000145 18: SwitchMame Managed Redundant Switch 09611
20: 20:

21: 21:

2 2

23 # [Location]: Switch Location 23 # [Location]: Switch Location

24 24

25 % --= max. length = 80 words 25 % --= max. length = 80 words

26 26

27: Location Switch Location 27: Location Switch Location
28 28

29 29

a0 a0

31: % [SysDescr]: Switch Description 31: % [SysDescr]: Switch Description

Iz Iz

I --= max. length = 30 words I --= max. length = 30 words

34 34

35; BysDescr MCA EDS-518A-55-8C 35; BysDescr EDS-4084 =

The inserted, deleted and modified lines in the configuration will be highlighted.

Device and Inventory Report

MXview can summarize device information in a formal report. Both a Device Availability Report and Inventory
Report are available.
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Device Availability Report

The device availability report includes information about Device IP, Device Alias, Availability average, and
Availability worst data. You can narrow the report by a specific time period by dates and groups.

Select Information - Availability Report

Availability Report

HAuailability Date Selection

Group | Any he Fram |20127%5 w| o~ To (201275 v

Device IP Device Alias Frorm date End date Availability Av.. | Availabilit..| Days
192,168,127 1 182.168.127.1 PT-7828 012-07-05  2012-07-05 100000 100.000 1[a
192.168.127.12 192.168.127.12 EDS- 4084 012-07-05  2012-07-05 100000 100.000 1
192.168.127.27 102.188.127.27 EDS-4084 012-07-05  2012-07-05 100000 100.000 1
182.168.127.41 182.168.127.41 EDS-4084 I012-07-05  2012-07-05 100000 100.000 1
162,168,127 42 192.188.127 42 EDS-4084 2012-07-05  2012-07-05 100000 100.000 1
192,168,127 44 192.188.127. 44 EDS-4084 012-07-05  2012-07-05 100000 100.000 1
192.168.127 43 102.158.127.43 EDS-4084 012-07-05  2012-07-05 100000 100.000 1
192.168.127 46 182.168.127 46 EDS-4084 I012-07-05  2012-07-05 100000 100.000 1
182,168,127 45 192,188,127 45 EDS-4084 2012-07-05  2012-07-05 100000 100.000 1
192,168,127 61 192.188.127 51 EDS-4084 012-07-05  2012-07-05 100000 100.000 1
192,168,127 62 182.160.127 52 EDS-4084 012-07-05  2012-07-05 100000 100.000 1
192.168.127 65 182.168.127 65 PT-510 I012-07-05  2012-07-05 100000 100.000 1
162.168.127 112 192.188.127.112 IKS-6726 Series  2012-07-05  2012-07-05 100000 100.000 1
192.168.127.155 192.188.127.155 EDS-4084 012-07-05  2012-07-05 100000 100.000 1
192.168.127.158 182.160.127.156 EDS-5084 012-07-05  2012-07-05 100000 100.000 1
192.168.127.160 182.188.127.160 EDS-4084 I012-07-05  2012-07-05 100000 100.000 1
192.168.127.154 192.168.127.164 EDS-4084 012-07-05  2012-07-05 100000 100.000 1
192.168.127.152 192.188.127 162 EDS-5084 012-07-05  2012-07-05 100000 100.000 1
192.168.127.115 182.168.127.115 ICMP Device 012-07-05  2012-07-05 B.715 B.715 1
182.168.127.350 182.188.127.250 EDS-5104 I012-07-05  2012-07-05 100000 100.000 1
192.168.127.153 192.168.127.153 ICMP Device 012-07-05  2012-07-05 100000 100.000 1
192.168.127 251 102.188.127.251 EDS-5184 012-07-05  2012-07-05 100000 100.000 1
192.168.127 181 182.168.127.181 ICMP Device I012-07-05  2012-07-05 100000 100.000 1
192.168.127.182 182.168.127.182 ICMP Device I012-07-05  2012-07-05 100000 100.000 1
192.168.127.153 192.168.127.183 ICMP Device 012-07-05  2012-07-05 17.588 17.588 1
192.168.127.240 102.188.127.240 PT-7528 012-07-05  2012-07-05 100000 100.000 1
4am 50 497 262 10 48 197 AED IAE Rra0G Sm oo P P 4

Exportto CEV ] [ Exportto POF ] [ Close
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The availability report can be exported to a PDF or CSV file.

Report Generate date:2012-07-05

Availability Report

From date:2012-07-05
End date:2012-07-05

Device availabih‘li !

Device IP

192.168.127.1
192.168.127.12

192.168.127.41

192.168.127.42

192.168.127.44

192.168.127.43
10 192.168.127.46
11 192.168.12745
12 192.168.127.61
13 192.168.127 62
14 192.168.127.65
15 192.168.127.112
16 192.168.127.155
17 192.168.127.156
18 192.168.127.160
19 192.168.127.164
20 192.168.127.162

]
i

1
2
3
4
5 192.168.127.27
&
7
8
9

192.168.127.115

22 192.168.127.250
23 192.168.127.153
24 192.168.127.251
25 192.168.127.181
26 192.168.127.182
27 192.168.127.183
28 192.168.127.240
29 192.168.127.253
20 192.168.127.248

]
e

192.168.127.249

32 192.168.127.254

Device Alfas

192.168.127.1 PT-7828
192.168.127.12 EDS4084A
192.168.127.27 EDS 4084
192.168.127.41 EDS4084
192.168.127.42 EDS4084
192.168.127 44 EDS408A
192.168.127.43 EDs 4084
192.168.127.46 EDS4084
192.168.127.45 EDS4084
192.168.127.61 EDS4084
192.168.127.62 EDS4084A
192.168.127.65 PT-510
192.168.127.112 IKS-6726 Series
192.168.127.155 EDS4084
192.168.127.156 EDS-5084
192.168.127.160 EDS-4084
192.168.127.164 EDS 4084
192.168.127.162 EDS-5084
192.168.127.115 ICMP Device
192.168.127.250 EDS-5104
192.168.127.153 ICMP Device
192.168.127.251 EDS-5184
192.168.127.181 ICMP Device
192.168.127.182 ICMP Device
192.168.127.183 ICMP Device
192.168.127.240 PT-7528
192.168.127.253 IC5-G7828
192.168.127.248 ICMP Device
192.168.127.249 ICMP Device
192.168.127.254 ICMP Device

Availability Average Availability Worst From date End date Days

6

17

6

100
100
100
100
100
100
100
100
100
100
100
100
100
100
100
100
100
100

M%)

100
100
100
100
100

588

100

L5

100
100
100

100
100
100
100
100
100
100
100
100
100
100
100
100
100
100
100
100
100
6.715
100
100
100
100
100
17.588

—
=
=

6.715
100
100
100

Device I Device Alias [Availability Aversge [Availability Worst [Fromdate  |Esddate  [Days
192.168.127.1  [152.168.127.1 PT-7828 100.000 100.000[2012 2012-07-05 1
192.168.127.12  [192.163.127.12 EDS 4084, 100.000 100.000 2012-07-05 1
19216812727  [192.163.127.27 EDS 4084 100.000 100.000[2012-07:05 [201207:05 1
15216812741 |152.168.127.41 EDS 4084 100.000 100.000 2012-07-05 1
15216812742 [152.168.127.42 EDS408A 100.000 100.000[2012-0705 [201207-05 1
19216812744 |192.163.12744 EDS 4084, 100.000 100.000[2012-07-05 [201207-05 1
19216312743 [192.163.127.43 EDS 4084 100.000 100.000[2012-07:05 [201207:05 1
19216812746 192168 127 46 EDS408A 100.000 100.000{2¢ 2012-07-05 1
19216812745 192168 127 45 EDS408A 100.000 100.000{ 2012-07-05 1
15216812761  [152.163.127.61 EDS 4084 100.000 100.000[2012-07-05 [201207-05 1
19216312762 |192.163.127.62 EDS 4084 100.000 100.000[2012-07:05 [201207:05 1
19216812765 192.168.127 65 PT-510 100.000 100.000 2012-07-05 1
192.168.127.112 192168 127 112 TKS-6726 Series 100.000 100.00 2012-07-05 1
152.168.127.155 [152.168.127.155 EDS-4064 100.000 100.000[2012-07-05 [201207-05 1
152.168.127.156 [152.163.127.156 EDS-5064 100.000 100.000[2012-07-05 [201207-05 1
192168127160 [192.168 127 160 EDS4064 100.000| 100.000[2012-07-05 [201207-05 1
192168127168 [192.163 127 164 EDS 4084 100.000 100.000[2012-07.05 [2012:07.05 1
152.168.127.162 [152.168.127.162 ED5-5064 100.000 100.000[2012-07-05 [201207-05 1
152.168.127.115 [152.168.127.115 ICMP Device 6715 6715[2012:07:05 [2012:07-05 1
192168127250 [192.168 127 250 EDS-3104 100.000| 100.000[2012-07-05 [201207-05 1
192163127153 [192.168 127153 ICMP Device 100,000 100.000[2012-07-05 [201207-05 1
152168127251 [152.168.127.251 EDS-3184 100.000 100.000[2012-07-05[2012407-05 1
152.168.127.181  [152.168.127.181 ICMP Device 100.000 100.000[2012-07:05 [201207-05 1
192168127182 [192.168 127,182 ICMP Device 100.000 100.000[2012-07-05 [201207-05 1
192163127183 [192.168 127 183 ICMP Device 17588 17.588[2012-07-05 |201207-05 1
152168127240 |152.168.127.240 PT-7528 100.000 100.000[2012-0705 [20120705 1
152168127253 |192.168.127.253 1CS-GT828 6715 6715[2012-0705 [2012-07-05 1
192168127248 [192.168 127248 ICMP Device 100.000 100.000[2012-07-05 [201207-05 1
192168127249 [192.168 127249 ICMP Device 100,000 100.000[2012-07-05 [201207-05 1
152.168.127.254 [152.168.127.254 ICMP Device 100.000 100.000[2012-0705 [20120705 1

A E 5 D E

20121115
2012715
20127115
20127115
20121115
2012715
20127115
20127115
20121715
20121115
2012715
20127115
20127115
20121715
20121115
2012715
20127115
20127115
20121715
20121115
2012715
20127115
20127115
20121715
20121115
2012715
20127115
20127115
20121715
20121115

20121115
2012715
20127115
20127115
20121115
2012715
20127115
20127115
20121715
20121115
2012715
20127115
20127115
20121715
20121115
2012715
20127115
20127115
20121715
20121115
2012715
20127115
20127115
20121715
20121115
2012715
20127115
20127115
20121715
20121115

i [ [ e e e | [ e e e | e i i e e e e i i e e e i e e [ fe

By default, the availability is calculated based on 24-hour intervals. To change this, in the menu select
Project >Preferences >Advanced > Devices > Timeframe for availability calculation

Enter the calculation timeframe base in the box and click OK. Units are entered in hours..
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Inventory Report

Select Information >Inventory Report to generate an inventory report.

Inventory report provides a summary of each device’s properties. With Inventory Report, MXview will export
reports separately for all the devices in your network. Each device has a single PDF Report. The PDF filename
is determined by device IP. The title of the report is the device alias, which you can edit in MXview. If there is
any third-party MIB compiled in, the proprietary information will be included into the report (refer to Chapter
13- MIB).

=lolx|
x

File Edit View Window Help

@@D@| "f3|— | HZ|= Tools%Sign%Comment

L Matt's Switch #2 0

Report Generate date: 2012-06-06

Property (Value 7
P 192.168.127.12

Device Alias (Matt's Switch #2

MAC Address 0090E819200B

sysDeser IMOXA EDS-408A

sysObjectld 136141860177

sysContact 89191230

sysName IManaged Redundant Switch 07022

sysLocation IMatt's Desk

modelName EDS-408A

firmwareVersion (V3.0 build 11070113

IpMask 255.255.2550

defaultGateway 0.000

dnsServerlIpAddr 0.000

snmpTrapCommunity [public |~
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Visualization Mode

The following topics are covered in this chapter.

a

a
a
a
a

VLAN Visualization

IGMP Snooping Visualization
Traffic Load Visualization
Security View

Wireless Dashboard



MXview Visualization Mode

VLAN Visualization

Moxa switches support 802.1Q tagged VLAN. MXview collects each device’s VLAN configuration and integrates
the information with color-coded visualization to provide a network-wide view.

1. Click the VLAN icon in the topology toolbox.

S o 5 5 e

2. After selecting a specific VLAN ID, devices, ports and links that are associated with the ID will be
color-coded.

To view the VLAN information in a table format, select Network - VLAN

% YLAN X
B02.10) rPnn—hased ]

Device IP fadel Lacatian WLAM 1D Joined Acces... Joined T... Manage..
192168127103 (Managed factary 1 1,23458678,.. M ~
192.168.127.102 (Managed Red...[Switch Locat... [1 1,23458678,.. M i
192.168.127.70  |Moxa EDS-51... [Switch Locat... [1 1,2345678,.. M
192168127 69  |Moxa EDS-51.. [Switch Locat. |1 12345678, . M
192168127 68  |Moxa EDS-51.. [Switch Locat. |1 1,23458678,. . M
192168127 67  |Moxa EDS-51... [Switch Locat... |1 1,23458678,.. M
192,168,127 66 [Moxa EDS-51... [Switch Locat... [1 1,23458678,.. M
192.168.127 65  |Moxa EDS-51... [Switch Locat... [1 1,23458678,.. M
192.168.127 64 |Moxa EDS-51... [Switch Locat... [1 1,2345678,.. M
192168127 63  |[Moxa EDS-51.. [Switch Locat. |1 1,23458678, . M
192168127 62 |Moxa EDS-51.. [Switch Locat. |1 1,23458678,. . M
192168127 61  |Moxa EDS-51... [Switch Locat... |1 1,2,3,47.891.. M
19216812714 [Moxa EDS-51... |factony 1 1,2,3,45691.. M
192.168.12713  |[Managed Red...|factory 1 1,23458678,.. M
19216812712 |Moxa EDS-40... [Switch Locat.. |1 1,23,45E67.8 M
19216812711  |Managed Red...[Switch Locat. |1 1,23458678, . M
192 168.127.2 Moxa PT-TE28. [factory 1 27,28, TK, M =
192.168.127 1 Managed Red...[factory 1 91011,12,13.... I v

IGMP Snooping Visualization

Moxa switches support IGMP snooping. MXview collects each device’s IGMP snooping configuration and
visualizes the information to provide a network-wide view.

1. Click the IGMP icon in the topology toolbox.

NG EEE rqur::“

2. After selecting a specific VLAN ID and multicast address, devices, ports and links that are associated with
the stream will be color-coded.
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Traffic Load Visualization

MXview collects the traffic load information of every link and displays the information to provide users with a

network-wide view.

1. Click the Traffic Load icon in the topology toolbox.

a2 [ L 2 7 O

2. The Traffic Load window pops up. It uses different colors to differentiate between different traffic load

levels.
[ Traffic Load @
Traific Load (%)
0 20 40 al a0 100
| Refresh |

3. All of the links will be color-coded to indicate how much traffic they are carrying.

.
MXV|@W Ineltsirdzl Maiwons eizigzmani Soitzire

4
Q.- Search Devices ’l LEEd
Device List Traffic Load ==
iy Root Traffic Lowd (%)
-9 192.168.127.1-EDS-GE 16E
. D 4 19
31921681272 B0 CocE pi(rCI0%) paT<1%) A O -
""" g 0 20 40 &0 g 100
----- 9 192.168.127.4-EDS-G516E
e ; p2(TX <1%) Pl (TH:10%)
Device Properties
----- Otoirtione meE || P! DCEE%) FR(TH )
_____ © HAC Adiross O0EZS5 192.168.127.3 192.168.127.2
@ twailability 13.57%
----- @ syslescr EDS-GSI6E |
----- @ sysiibjectld 136141, -
) sysContact Ring 1 Master
..... O systlane H P2 (TH<1%) pITX<1%)
----- @ syslocation Switch Locat
O ifNunber
® interface 1 wo S/ |
-] interface 2 w o S16/ | 192,166 127 4
® interface. 3 down £ 10M .|
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4. Navigate to Project > Preferences > Appearance to redefine the traffic load levels.

Preferences

| Basic

2?3 User

@ Dis;.play

b Topology

k_‘ Appearance
k_‘ Device Appearance

@ Advanced

",
}‘; System Configuration
; T,

. x’;’ Device
; L

2

}!"; SMNMP Configuration

u:;) Events

Language

‘English

Background Color

[ ] 255 255 255

Status Color

Turbo Ring V1 Color

Appearance

PoE link Color

oo

Turbo Ring V2 Color

| Al oo v

Turbo Chain Color RSTP Color

oo | Al -

Link up Color Link down Color

| [N | [N v

Traffic Load(%)

1] 20 40 a0l a0 100

oK | Close

Security View

ISA/IEC 62443 is a continuously evolving cybersecurity standard whose guidelines have already been adopted
in many industrial automation applications. This standard, including its subsections, aims to cover points such
as general requirements, policies & procedure, system-level requirements, and component-level

requirements.

Moxa’s MXview follows Moxa’s security guidelines, which are based on the current IEC 62443-4-2
component-level recommendations. Security View checks the security level of Moxa’s network devices. There
are five levels for checking the results in Security View:

High: IEC 62443-4-2 level 2
Medium: IEC 62443-4-2 level 1
Basic: General baseline

Open: Security Level below basic

Unknown: Devices without security-related information for MXview

NOTE

The definition of general baseline is based on several industrial cybersecurity policies and requirements.

1.

Click the Security View icon in the topology toolbox

e e e e @O
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The Security View window pops up. Different colors indicate different security levels, and all devices are

color-coded with their respective security levels.

. MXview = [l
Project View Device Link Information Event Tools MIB Help
7
MO VieW Lidisisdal isivors Sanagamsni S MOX/\
4

i ST
Device List P Security view == =] 1]
=4 RoOt

N F\IIev 1P Address: 192.166.127.3 Security Level: High

e

S p2 |P Address Check ltems Current Setting H M B

Device Properties

192 .168.127.1

[Enable Auto Logout Enabled
Sef Login Message Set

Disable Non-encrypted TCP/UDP Ports Enabled
[Enable Account Login Failure Lockout Enabled
[Enable Trusted Access Enabled

Enable Password Complexity Strength Check |Enabled
Enable C File Encrypiion Enadled
Enable Broadcast Storm Protection Enabled
[Set SNIP Trapfinform or Syslog Server Set

Change Default Password / SNWP Communit.. | Changed

B qion [llvesum [ sasic [ Jopen [ | Unknown
T ——

[ Launeh MXconfig ] [ Export ] [ Scan ] [ Close. ]
q v
ot 1 RecentEvents | AckAl | [Unscked LostFittrBvents 12 w | [ s All Events
Ack D Source Source P Device Allas Severily Description Time Issued
=} 278 Trap 192.168.127.2 192.168.127.2-EDS-51... Warning Authentication failure 2016-09-19 13:22:20 o
Q De. Fit @ &} 217 Trap 192168 127 2 192168 127 2-EDS-51__ Informalion :;C““m authentication fail ¢ 09 19 13.:22:20
. Topology has been saved successtully ‘ e 019230 ‘ Managed Devices (Current/ Max) = 3120

Users can see the Check Items and Current Settings in the window. H, M, B indicates High, Medium, and

Basic levels. Q indicates the Check Item has been successfully setup, ° indicates the Check Item is

unnecessary for that level, and BLANK indicates the Check Item has not been successfully setup yet.

EFA Security view

== =]

Filter IP Address: 192.168.127.2

IP Address

Security Level: Medium

Check ltems Current Setting H M
Enable Auto Logout Enabled [ 2K -]
Set Login Message Set [ 3]
Disable Non-encrypted TCP/UDP Ports Enabled [ 3K-]
Enable Account Login Failure Lockout Enabled [] ?
Enable Trusted Access Enabled [ 3]
Enable Password Complexity Strength Check  |Enabled [] ?
Enable Configuraiton File Encryption Disabled [-]
Enable Broadcast Storm Protection Enabled [ K]
Set SMMP Trap/inform or Syslog Server Set -]
Change Default Password / SNMP Communit... |Changed [ 3K-]

- High -Medium -Elasic I:IDpen I:lUnknown
e ]

l Launch MXconfig H Export ] [ Scan

[
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4. By using Filter, users can select devices with a specific security level in the window.

A Security view EI = @
Filter | Medium ~ | IP Address: 192.168.127.2 Security Level: Medium
IP Address Check ltems Current Setting H M B
Enable Auto Logout Enabled [ 2R -]
Set Login Message Set [ - RE-)
Disable Mon-encrypted TCP/UDP Ports Enabled [ - RE-]
Enable Account Login Failure Lockout Enabled 00 Q]
Enable Trusted Access Enabled [ RK-]
Enable Password Complexity Strength Check  |Enabled [ - 2]
Enable Configuraiton File Encryption Disabled Q9
Enable Broadcast Storm Protection Enabled [ - RE-)
Set SNMP Trap/inform or Syslog Server Set [ IE-3K-]
Change Default Password / SMMP Communit .. |(Changed [ K- 3K-]

- High -Medium -Elasic I:IDpen I:IUnknown
e

l Launch Mxconfig ”

Export ] [ Scan

I

Close

l

5. Click Export to export the details of the devices’ IP addresses, Check Items, and Current Settings in a CSV

file.

EFA Security view

(=)= =]

IP Address: 192.168.127.2

Security Level: Medium

IP Address

Check ltems Current Setting H M B
Enable Auto Logout Enabled [ 2B~}
Set Login Message Set [ -]
Disable Non-encrypted TCP/UDP Ports Enabled [ 3K RI-]
Enable Account Login Failure Lockout Enabled A=)
Enable Trusted Access Enabled [ K- 3]
Enable Password Complexity Strength Check |Enabled A=)
Enable Configuraiton File Encryption Disabled [-3[-]
Enable Broadcast Storm Protection Enabled [ -]
Set SMMP Trap/inform or Syslog Server Set [ JE-3K-]
Change Default Password / SNMP Communit... |Changed [ 3R]

- High -Medium -Elasic I:IDpen I:lUnknown
e ]

l Launch MXconfig ]

Export ] [ Scan

l l Close

l
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6. Click Launch MXconfig to activate MXconfig for mass configuration of security-related parameters. In the
Security Wizard of MXconfig, all parameters relating to the different security levels can be listed, and users
can easily enter their information for mass configuration.

EE Security view El = @
Filter IP Address: 192.168.127.2 Security Level: Medium

IP Address Check ltems Current Setting H M B
Enable Auto Logout Enabled [ 2K BK -]
Set Login Message Set [ 3K RI-]
Disable Non-encrypted TCP/UDP Poris Enabled A
Enable Account Login Failure Lockout Enabled [ - 3-]
Enable Trusted Access Enabled [ 3]
Enable Password Complexity Strength Check  |Enabled [ -]
Enable Configuraiton File Encryption Dizsabled [-3K-]
Enable Broadcast Storm Protection Enabled A=)
Set SNMP Trap/inform or Syslog Server Set 121

© oo

Change Default Password / SMMP Communit... (Changed

- High -Medium -Elasic I:IDpen I:lUnknown
e ]

l Launch MXconfig l Export [ Scan ” Close l

M¥cenfig ===
File Edit Help
A=l elelR al ¢oess) s e el
AL : Model IP Adddress MAC Address Serial Firmware Version ~ Mame Location
Impart Device ===

Please select the types of devices you want to search

Active | Device Type Progress Status

El Industrial Terminal Server Preparing .
[l Industrial Wireless Preparing | |
v Industrial Ethernet Switches/Secure Routers/DSL Exte... Preparing |-
]l Industrial IP Cameras/Video Encoders/Video Decoder. Preparing
W] Industrial Device Server Preparing
v Industrial Ethernet Gateway Preparing ~

Timeout 500 ms Retry

Device List

192 188127 1
192.188.127.2
192.168.127.3

Information
LLDP

Forwarding

Interface
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& Mxconfig ===
File Edit Help
= ; = G| A Y
HeE et &l gloleen) aelcs o o €@
h ALL ) )
92.168.127.1 L ) Model IP Adddress MAC Address Serial Firmware Version ~ Name Location
192.168.127.2 ﬁ EDS-510E-3GTXSFP 182.168.127.2 0090E84BD034 01961 V5.2build16091412
192.168.127.3 a EDS-G516E-T 192.188.127.3 0090EB54E1ER 08477 V5.0build18070518 Switch Location
a EDS-405A 192.168.127.1 0090E32D049F 06217 V3.4 8build14121815Managed Redunda... Switch Location
3 Security Wizard ==
File View
q -
. [l
Display  IP Address -

Selected devices

192.168.127.2 .
192168127 3 Enable Name

(Auto Logout

m

faccessible IP

Syslog Server

[Trap Server

'SNMP Setting

Password

Load setftings from this device

ftion

Next I I Cancel I

ing
Ne tmask 255.255.255.0 Interface

Gatevay 0.0.0.0
MAT Address 00-90-E%-2D-04-5F

Total Count: 3

NOTE For a detailed introduction of MXconfig Security Wizard, please see MXconfig HELP.

7. Navigate to Project > Preferences 2> Security View to redefine the color of the different security levels.
Users can also define their own security profile by selecting User-defined Profile. All of the check items can
be set for Security View, and it shows Pass or Not Pass for checked results.

154 Preferences @
,é User Security View
----- & % Account Management
y Profile Built-in Profile -
----- & a Password Paolicy L 4

) ) X Colors for check result
----- & ~ Login Notification

,0 Display

Medium /1EC 62443-4-2 Level 1
----- Bl Topology -
_____ u Appearance - ~ Basic/General Baseline

----- u Device Appearance I:I | e
..... [ 7] Profile details-

,0 Advanced

- + High/IEC 62443-4-2 Level 2

40 ;) SNMP Configuration
-4 (0 ;)Events
%

2 Management Interface

oK | Close
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154 Preferences

.\9 User

----- ??3 Account Management
----- ??3 Password Policy

----- ??3 Lagin Notification

.\i? Dis.pla\y

_____ Bl opoiogy

;#;) System Configuration
; L

Device

LN
3 SNMP Configuration

L,
2

*’5) Events
~

;,;) Management Interface

Security View

Profile 'Userdeﬂned -

Colors for check result

- ~ Pass
I:l ~ MotPass

Switch | Gateway

==

Enabled Check Item
Enable Auto Logout

oG

Set Login Message

Disable Mon-encrypted TCP/UDFP Ports

Enable Account Login Failure Lockout

Enable Trusted Access

Enable Password Complexity Strength Check

Enable Configuraiton File Encryption

Enable Broadcast Storm Protection

Set SNMP Trap/nform or Syslog Server

i o o

Change Default Password / SNMP Community String

oK |

Close

Below is the detailed description for each item:

Enable Auto Logout: Check if the Auto Logout function is enabled or not

Set Login Message: Check if the Login Message is set or not
Disable Non-encrypted TCP/UDP Ports: Check if the Non-encrypted TCP/UDP Ports are disabled or not

Enable Account Login Failure Lockout: Check if the Account Login Failure Lockout function is enabled or

not

Enable Trusted Access: Check if the Trusted Access function is enabled or not

Enable Password Complexity Strength Check: Check if the Password Complexity Strength Check

function is enabled or not

Enable Configuration File Encryption: Check if the Configuration File Encryption function is enabled or

not

Enable Broadcast Storm Protection: Check if the Broadcast Storm Protection function is enabled or not

Set SNMP Trap/Inform or Syslog Server: Check if the SNMP Trap/Inform or Syslog Server is set or not

Change Default Password/SNMP Community String: Check if the Default Password or SNMP
Community String is set or not
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Wireless Dashboard

MXview collects the wireless information from all the Moxa AWK series devices, and displays the information
into a Wireless Dashboard for an overview.

1. Navigate to Information > Wireless Dashboard to activate the Wireless Dashboard.

2. All the Access Points (APs) and Clients are listed. Device Name, IP Address, MAC Address, Signal Strength,
and SNR are shown on the dashboard. Furthermore, the connection between the APs and Clients can also
be shown on the dashboard.

=3 Wireless Dashboard - m} X
Auto Refresh: 14 Search: e 3
Number of APs: 3 Number of Clients: 3
Signal
Device Name IP Address MAC Address D me |P Address MAC Address Strengthi |SNR (dB)
(dBm)
AWK-4131A-US_2 20.20.88.2 00:90:E8:53:3C:B2 AWK-4131A-US_3 20.20.88.3 00:90:E8:53:3C.AB -106 4
AWK-3131A_4697q 10.10.14.2 00:90:E8:58:8F:85 AWK-3131A_4761 10.10.14.3 00:90:E8:58:8F:C5 -75 23

AWK-1131A-EU_4 10.10.14.4 00:90:E8:59:A8:3E AWK-1131A-EU_5 10.10.145 00:90:E8:59:A8:8E

Slgnal
IP Address MAC Address IP Address MAC Address Strength |SNR (dB)
(dBm)

Show XSS Entries

3. By clicking the E icon, users can set the threshold for Signal Strength and SNR. In the meantime,

different colors can be set for indication on the dashboard.

Enable Parameter Column Condition WValue Color
Signal Strength (dBm) = ]
SNR (dB) == 0

OHH
S

NOTE Only the AWK-1131A series, AWK-3131A series, and AWK-4131A series support Wireless Dashboard.

NOTE Wireless Dashboard is refreshed automatically every 15 seconds.
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MIB

MXview’s embedded MIB compiler supports third-party MIB files. After compiling the MIB file, any device’s
parameter can be monitored in MXview.

This chapter covers the following application tools of the MIB compiler:

0O MIB Browser
0O OID Import Manager
O Trap Import Manager
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MIB Browser

MIB browser provides an easy and comfortable browsing interface for reading proprietary MIB parameters. OID
import manager makes all monitored parameters customizable, and they can be read in the device properties
window list. With Trap Import Manager, the third-party traps can be displayed in the event history box.

MIB Browser is a simple and fast interface that lets you browse MIB files. It is able to load third-party MIB files.
After loading the MIB, the OID tree will be listed in the left column. You can unfold these OIDs and get the
parameter you need.

To open the MIB Browser: Select MIB ->MIB Browser

=]
Flle About
§ ) RFC1213-MIB
| OLD-CISCO-CPU-MIE AgentIP: 152.186.127 252 SHME v1
= VALUES
E'_) OID: 1361419221166
i 9 busyPer (56)
1 aveBusyl (57) Gt | cetwe | cetsubme | Wk | set
P aveBusyS (58)
2 idleCount (59) NameOID Folue
Foe 2 idleWined (50) busyPer 3 =
avgBusyl ]
avgBusys 3
I@;cum 55
ik Wi 0]

136141921610 |cisco Systemss, Inc 170 West Tasmon D San Joce, CA 95134-170611.5 A Ph +1-408-526-40
136141921620  [18024

136141921630
136141921640
136141921650
136141921660
126141021670
136141021680
136141921690
home  depu (1) 136141921700
oD 136141921 136141921710 |
(VALUE lepu OBUECT | | (136141921720 0000
description | DENTIFIER 136141921730 |fash#2950-shqdl3-mz 121-11 EAL bin
- 136441921 | (12614192140 3

1361419231111 [Fast Elfwrmet
1261410221013 [Fast Ethermet
1361410220115 [Fast Ethernet -

!IE‘ Choee

e Click File >Load MIB to load a MIB file.

e Select the item in the MIB tree:

e Click Get to get the parameter of selected item.

e Click Get Next to get the OID next to the item you selected.
e C(Click Get Subtree to get all the OIDs in the sub tree folder.
e Click Walk to get the OID’s parameter in sequence.

e Click Set to set up parameters of the selected OID.
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OID Import Manager

OID Import manager helps to add specific OID items for SNMP polling. It supports third-party MIB with polling.
After compiling the MIB files, you can monitor third-party OIDs through SNMP polling.

To open the import manager: Select MIB - OID Import Manager

© OID Import Manager !.E
Lizt of Palling OIDs

s e Show Details
CFU avgBusys 136141921580
CPULavgBusyl 136141921570 JrR—
136141821560

CPT busyPer
CPU.idle Wired 136141021600

CITidleConnt 1361415921580

Modify
Delete

Close

e List of Polling OIDs lists all specific polling items.

e Click Show Details to see the OID name, OID, and the devices which this OID is assigned to.
e Click Add to add an OID form the standard MIB or a third party MIB
e Click Modify to modify an imported OID’s name.

e Click Delete to remove an imported OID
There are two steps to add a new OID and assign it to the specific device.

1. Add a specific OID
Click Add to add a new OID for polling. A window will pop up. You can import MIB files by selecting File >
Load MIB. In this window you can edit the Name for the OID you selected. This name will be displayed in
the device properties window.
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File
| RFCIZ13-MIE
= |, VALUES
= ) mib-2 {1}
. system (1)
| interfaces (2)
LAt
i 1361214
L demp (5)
. tep ()
L udp (7)
ki 20 ) Test [3
# transmission (10)
ki

smp (11}

Operation @) et

Name |
Value

OID Description

VALUE ip OBJECT IDENTIFIER
=1261214

Click the Test button to try to get the OID parameter first. You can find the description for this OID in the
OID description window. Click the Add button to add this OID into the import manager.

2. Assign polling OID to the device

Click the Assign button in OID import manager. An Assign Polled Devices window will pop up

[ [ Assign Polled Devices

Name iplnDelivers OID 136121450

Al
List of Devices List of Selected Devices
192.168.127 36 (192168127 36 ICMP Device) 192.168.127 3 (192.168.127 3 EDS-4084)

192.168.127.38 (192.165.127 .38 ICMP Device) Add 192.168.127 4 (192.168.127 4 EDS-4084)
192.1688.127 253 (192.168.127 253 [KR-36924)

Add All

Remove

Remaove All

This window will list all devices in the network. Select the device you wish to assign then click Add. The
selected device will be moved to the right. After selecting the device, click Assign to finish.

After adding a device, click the device in the main screen. The third-party MIB OID can be read in the device
property window.
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Device Propeties
- interface. 20 dowm / 10M / ﬂ
- interface. 21 dovm / 10M 7
- interface. 22 dowm / 10M 7
™ interface.23 dowm [/ 10M /
F-{®| interface. 24 down / 100M /
- interface. 25 down / 10M /
- interface. 26 dowm / 10M /
- interface.27 up A=1/
™ interface. 28 up A1/
""" % ipadEntiddr.192.168.127.252 192.1
----- "';3 CPU.busyPer 1
----- % CPU. awgBusyl 4
----- k';) CPT. avgBusys 4
----- t9 CPU.idleCoumt 4036
""" o CPU.idleWired a -
4 »

Trap Import Manager

Trap Import Manager can read third-party MIB files, and compile the MIB into MXview. With this tool, MXview
can understand traps from third-party MIBs.

To open the trap import manager, select MIB - Trap Import Manager

75 Trap Import Manager g@

List of Traps
L Tezp OID Show Details
¢2000R psFailsd BT
¢ 2900 road castStorm 1361416987202
+2000Add ressViolation 1361419987201

Impart
Modify Description

Delete

Close

e The list of traps column will list all the traps which are already imported.
e Click Show Details to read detailed information, including Trap Name, OID, and its descriptions.
e Click Import to load MIB files and select the trap to import.

e Click Modify Description to name the description for the Trap. The description here will be the trap event
which shows in the event list.

e Click Delete to remove an imported Trap.
There are three steps to add a new Trap to MXview.

1. Load a MIB

Click the Import button. The Import Dialog window will pop up. Then click Load MIB and select a MIB file
to load.

After the MIB is loaded, click Parse. The column on the right will list all the Traps.
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Load MIE ] [ Remave MIE £2800AddressViolation

CISCO-C2800-MIE. my
c2800BroadeastStorm

c2900RpsFailed

linkDown

linklp

coldStart

wartn Start

farse ] authenticationFailure

2. Select Trap to import

c2800AddressYiolation

c2900BroadeastStorm

c2900RpsFailed

linkDowen

linkUp

coldStart

warmStar

authenticationFailure

U8 B8 E E EE

b

Select the check box corresponding to the Trap you would like to import.

Click the button behind each Trap to show its OID and the original description of its MIB.

(i c2900AddressYiolation
oD 1.36.1.4.1.9.8.87.2.0.1
Enterprise 13614199872
VALUE c29004ddressViolation NOTIFICATION-TYFE ¢ &

Objects: [1.3.6.1.4.1.9.8.87.1.4.1.1.25]
Btatus: Current
Description: The addressViolation notification 15 generated
when an address violation is detected
o a secured port, The generation of the
addressViolation notification can be enabled
or suppressed using the ohject
c2900ConfigaddressViolationtction,
The particular secured port 15 Indicated by
the walne af c?A00PartTfIndas hd

Cloge

3. Edit description

In the Trap list, the description field is editable. You are able to write a customized description here.

C2900Addressviolation \‘EEQDDAddrESSViDIatiDn

L]

When finished, click the Import button. The dialog will be closed and returned to the Trap Import

Manager window. You will find imported Traps in your List.
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75 Trap Import Manager

M= X

Listof Traps

Name Trap QID
c2900R psFailed 1361419987303
£2900B10ad castitorm 1361419987202
29004 dd ressV inlation 1361419987201

Show Details

Impart

Modify Description

Delete

Close

NOTE

The system will notify you with a pop-up window if an OID has already been imported.

Information

\1) "c29004ddressVinlation" is already known
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MXview License

MXview is available in different versions, which the different versions supporting different numbers of nodes.
For example, if your version of MXview supports 250 nodes, then during device discovery MXview will only
recognize up to 250 nodes. MXview will stop the device discovery procedure once it reaches the 250-node limit.

The MXview license that you purchase specifies the node limit for that version of MXview. To increase the node
limit, you can purchase license upgrade and import the upgrade into MXview.

Checking the License

The number of currently managed nodes and the node limit is shown in the Status Bar on the Dashboard.

The Mumber of Managed Devices f Max: 24 750

To check the details, select Help < License.

W License rzl

MHumber of Managed Devices § Max

Editinn Key Letivation Time Add License
Cornercial-S00 |DYFHLHALT??CRDP31-I4MF5WISYAE |2IZIIZIEJ-11-IZI4 11:52:06

Close

License Upgrade

To increase the node limit of your MXview, you need upgrade the license.

1. Select Help - License.
2. Click Add License.

% License § |

Humber of Managed Devices f Max

Edition Eew Activation Time Add License
Commercial-500 |DYFHLHAU?TCRDP3H4MF5WISYAE |2EIE|9-11-D=-1 11:52:06

Cloze




MXview MXview License

3. Find the license label in the software package, which is shown as:

MXview Upgrade-50
Ky XXX XXXXXXOOCOHAKX

4. Enter the key of the new license and click OK.

Input License kKey

o [cmen |

5. Restart the MXview client.
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FAQ

Why do events show up late?
Make sure you have configured your switches’ SNMP trap server to the MXview server’s IP address, since doing
so will provide real-time responses to events. Otherwise, MXview will collect information periodically.

Why can’t I discover all of the devices on my network?
Please check the following:

1. Make sure your license supports a sufficient number of nodes.
2. Make sure your scan range includes all of the IP addresses of devices on your network.

Make sure your switches do not go into protection mode because they consider MXview packets to be part
of a broadcast storm.

Why does one device have more than one icon?
MXview identifies devices by IP address. For this reason, if one device has more than one IP address within the
scan range, the device will be viewed as multiple devices.

Will deleting a link in MXview cause the link to be disconnected in the real
network?

No. The topology map shows the status of the real network, but cannot be used to configure the real network.

After a link in a ring is disconnected, why does it take a few seconds for the
redundant link to become solid in the topology map?

MXview uses polling to determine if redundant links have become non-redundant. For this reason, the topology
map will not be updated until all devices in the network have been polled. In addition, since it takes a finite
amount of time to transmit the network status to the MXview server, it will take at least that amount of time for
the topology map to be updated.
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License (Net-SNMP)

Various copyrights apply to this package, listed in several separate sections below.

Please carefully review all sections of the license information.

---- Part 1: CMU/UCD copyright notice: (BSD like) -----

Copyright 1989, 1991, 1992 by Carnegie Mellon University

Derivative Work - 1996, 1998-2000

Copyright 1996, 1998-2000. The Regents of the University of California

All Rights Reserved

Permission to use, copy, modify and distribute this software and its documentation for any purpose and without
fee is hereby granted, provided that the above copyright notice appears in all copies and that both that
copyright notice and this permission notice appear in supporting documentation, and that the name of CMU and
The Regents of the University of California not be used in advertising or publicity pertaining to distribution of
the software without specific written permission.

CMU AND THE REGENTS OF THE UNIVERSITY OF CALIFORNIA DISCLAIM ALL WARRANTIES WITH REGARD TO
THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT
SHALL CMU OR THE REGENTS OF THE UNIVERSITY OF CALIFORNIA BE LIABLE FOR ANY SPECIAL, INDIRECT
OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM THE LOSS OF USE, DATA
OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING
OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

---- Part 2: Networks Associates Technology, Inc copyright notice (BSD) -----

Copyright (c) 2001-2003, Networks Associates Technology, Inc

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that
the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following
disclaimer.
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* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution.

* Neither the name of the Networks Associates Technology, Inc nor the names of its contributors may be used
to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
COPYRIGHT HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 3: Cambridge Broadband Ltd. copyright notice (BSD) -----

Portions of this code are copyright (c) 2001-2003, Cambridge Broadband Ltd.

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that
the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following
disclaimer.

* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution.

* The name of Cambridge Broadband Ltd. may not be used to endorse or promote products derived from this
software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER “AS IS” AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 4: Sun Microsystems, Inc. copyright notice (BSD) -----

Copyright © 2003 Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,

California 95054, U.S.A. All rights reserved.
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Use is subject to license terms below.
This distribution may include materials developed by third parties.

Sun, Sun Microsystems, the Sun logo and Solaris are trademarks or registered trademarks of Sun
Microsystems, Inc. in the U.S. and other countries.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that
the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following
disclaimer.

* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution.

* Neither the name of the Sun Microsystems, Inc. nor the names of its contributors may be used to endorse or
promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
COPYRIGHT HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 5: Sparta, Inc copyright notice (BSD) -----

Copyright (c) 2003-2009, Sparta, Inc

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that
the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following
disclaimer.

* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution.

* Neither the name of Sparta, Inc nor the names of its contributors may be used to endorse or promote
products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
COPYRIGHT HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
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HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 6: Cisco/BUPTNIC copyright notice (BSD) -----

Copyright (c) 2004, Cisco, Inc and Information Network
Center of Beijing University of Posts and Telecommunications.

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that
the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following
disclaimer.

* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution.

* Neither the name of Cisco, Inc, Beijing University of Posts and Telecommunications, nor the names of their
contributors may be used to endorse or promote products derived from this software without specific prior
written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
COPYRIGHT HOLDERS OR

CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
ANY THEORY OF LIABILITY,

WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 7: Fabasoft R&D Software GmbH & Co KG copyright notice (BSD) -----

Copyright (c) Fabasoft R&D Software GmbH & Co KG, 2003
oss@fabasoft.com

Author: Bernhard Penz

Redistribution and use in source and binary forms, with or without modification, are permitted provided that
the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following
disclaimer.
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* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution.

* The name of Fabasoft R&D Software GmbH & Co KG or any of its subsidiaries, brand or product names may
not be used to endorse or promote products derived from this software without specific prior written
permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER “AS IS” AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,

WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 8: Apple Inc. copyright notice (BSD) -----

Copyright (c) 2007 Apple Inc. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that
the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the
following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of Apple Inc. (“"Apple”) nor the names of its contributors may be used to endorse or
promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY APPLE AND ITS CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL APPLE OR ITS CONTRIBUTORS
BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 9: Sciencelogic, LLC copyright notice (BSD) -----

Copyright (c) 2009, Sciencelogic, LLC

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that
the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following
disclaimer.
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* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution.

* Neither the name of Sciencelogic, LLC nor the names of its contributors may be used to endorse or promote
products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
COPYRIGHT HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The MIT License (Libxml2)

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated
documentation files (the “Software”), to deal in the Software without restriction, including without limitation
the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and
to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of
the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE
FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
DEALINGS IN THE SOFTWARE.

License Agreement (GoAhead)

THIS LICENSE AGREEMENT IS BETWEEN YOU AND GOAHEAD (BOTH AS DEFINED BELOW). THIS AGREEMENT
GRANTS YOU ONLY A LIMITED LICENSE TO USE GOAHEAD PROPRIETARY COMPUTER SOFTWARE. BY
EXECUTING THIS AGREEMENT OR USING THE SOFTWARE, YOU CERTIFY THAT YOU WILL USE THE SOFTWARE
ONLY IN THE MANNER PERMITTED HEREIN.

1. Definitions.

“Documentation” means any documentation GoAhead provides with the Original Code.
“GoAhead” means GoAhead Software, Inc.

“Agreement” means this document.

“Modifications” means any addition to or deletion from the substance or structure of either the Original Code
or any previous Modifications.

“Original Code” means the source code to GoAhead’s proprietary computer software entitled GoAhead
WebServer that is provided to You by GoAhead.

“You"” means an individual or a legal entity exercising rights under, and complying with all of the terms of, this
license or a future version of this license. For legal entities, “You” includes any entity that controls, is controlled
by, or is under common control with You. For purposes of this definition, “control” means (a) the power, direct
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or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (b)
ownership of fifty percent (50%) or more of the outstanding shares or beneficial ownership of such entity.

“"Response Header” means the first portion of the response message output by the GoAhead WebServer,
containing but not limited to, header fields for date, content-type, server identification and cache control.

“Server Identification Field” means the field in the Response Header which contains the text “Server:
GoAhead-Webs".

2. License.
Limited Original Code Grant.

Subject to the terms of this Agreement, GoAhead hereby grants You a worldwide, royalty-free, nonexclusive,
nontransferable license, without right of sublicense, subject to third party intellectual property claims, (a) to
use and reproduce the Original Code, (b) to create Modifications from the Original Code, and (c) to distribute
source code copies of the Original Code form solely when embedded in other software (in @ manner that does
not allow the Original Code to be separated) that provides material functionality in addition to the functionality
provided by the Original Code.

Binary Code.

Subject to the terms of this Agreement, GoAhead hereby grants You a worldwide, royalty-free, nonexclusive,
nontransferable license, without right of sublicense, to copy and distribute binary code copies of the Original
Code together with Your Modifications in binary code.

Restrictions on Use.

You may sublicense third parties to use Your Modifications if You enter into a license agreement with such third
parties that bind such third parties to all the obligations under this Agreement applicable to You and that are
otherwise substantially similar in scope and application to this Agreement (without limiting the protections
afforded to GoAhead). You may not rent, lease, or loan the software.

Documentation.

Subject to the terms of this Agreement, GoAhead hereby grants You a worldwide, royalty-free, nonexclusive,
nontransferable license, without right of sublicense, to copy and distribute the Documentation in connection
with the authorized distribution of the Original Code and Modifications.

Copyright Notice.

You agree to include copies of the following notice (the “Notice”) regarding proprietary rights in all copies of the
Original Code and Modifications that You distribute, as follows: (a) embedded in the binary code; and (b) on the
title pages of all documentation. Furthermore, You agree to use commercially reasonable efforts to cause any
licensees of your products to embed the Notice in object code and on the title pages or relevant documentation.
The Notice is as follows: Copyright (c) 20XX GoAhead Software, Inc. All Rights Reserved. Unless GoAhead
otherwise instructs, the year 20xx is to be replaced with the year during which the release of the Original Code
containing the notice is issued by GoAhead. If this year is not supplied with Documentation, GoAhead will
supply it upon request.

License Back to GoAhead.

You hereby grant in both source code and binary code to GoAhead a world-wide, royalty-free, non-exclusive
license to copy, modify, display, use and sublicense any Modifications You make that are distributed or planned
for distribution. Within 30 days of either such event, You agree to ship to GoAhead a file containing the
Modifications (in a media to be determined by the parties), including any programmers’ notes and other
programmers’ materials. Additionally, You will provide to GoAhead a complete description of the product, the
product code or model number, the date on which the product is initially shipped, and a contact name, phone
number and e-mail address for future correspondence. GoAhead will keep confidential all data specifically
marked as such.

3. Terms, Trademards and Brand.

License and Use.
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GoAhead hereby grants to You a limited world-wide, royalty-free, non-exclusive license to use the GoAhead
trade names, trademarks, logos, service marks and product designations posted in Exhibit A (collectively, the
“GoAhead Marks") in connection with the activities by You under this Agreement. Additionally, GoAhead grants
You a license under the terms above to such GoAhead trademarks as shall be identified at a URL (the “"URL")
provided by GoAhead. The use by You of GoAhead Marks shall be in accordance with GoAhead’s trademark
policies regarding trademark usage as established at the Web site designated by the URL, or as otherwise
communicated to You by GoAhead at its sole discretion. You understand and agree that any use of GoAhead
Marks in connection with this Agreement shall not create any right, title or interest in or to such GoAhead Marks
and that all such use and goodwill associated with GoAhead Marks will inure to the benefit of GoAhead.

Promotion by You of GoAhead WebServer Mark.

In consideration for the licenses granted by GoAhead to You herein, You agree to notify GoAhead when You
incorporate the GoAhead WebServer in Your product and to inform GoAhead when such product begins to ship.
You agree to promote the Original Code by prominently and visibly displaying a graphic of the GoAhead
WebServer mark on the initial Web page of Your product that is displayed each time a user connects to it. You
also agree that GoAhead may identify your company as a user of the GoAhead WebServer by placing your
company logo on its Web site. You may further promote the Original Code by displaying the GoAhead
WebServer mark in marketing and promotional materials such as the home page of your Web site or Web pages
promoting the product. You also agree to use the latest available logo and script code from GoAhead available
from the official GoAhead download location.

No Modifications to Server Identification Field.

You agree not to remove or modify the Server identification Field contained in the Response Header as defined
in Section 1.7 and 1.8.

4, Term.

This Agreement and license are effective from the time You execute this Agreement until this Agreement is
terminated. You may terminate this Agreement at any time by uninstalling or destroying all copies of the
Original Code including all binary versions and removing any Modifications to the Original Code existing in any
products. This Agreement will terminate immediately and without further notice if You fail to comply with any
provision of this Agreement. All restrictions on use, and all other provisions that may reasonably be interpreted
to survive termination of this Agreement, will survive termination of this Agreement for any reason. Upon
termination, You agree to uninstall or destroy all copies of the Original Code, Modifications, and
Documentation.

5. Warranty Disclaimers.

THE ORIGINAL CODE, THE DOCUMENTATION, AND THE MEDIA UPON WHICH THE ORIGINAL CODE IS
RECORDED (IF ANY) ARE PROVIDED “AS IS” AND WITHOUT WARRANTIES OF ANY KIND, EXPRESS,
STATUTORY OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE, AND NON-INFRINGEMENT.

The entire risk as to the quality and performance of the Original Code (including any Modifications You make)
and the Documentation is with You. Should the Original Code or the Documentation prove defective, You (and
not GoAhead or its distributors, licensors or dealers) assume the entire cost of all necessary servicing or repair.
GoAhead does not warrant that the functions contained in the Original Code will meet your requirements or
operate in the combination that You may select for use, that the operation of the Original Code will be
uninterrupted or error free, or that defects in the Original Code will be corrected. No oral or written statement
by GoAhead or by a representative of GoAhead shall create a warranty or increase the scope of this warranty.

GOAHEAD DOES NOT WARRANT THE ORIGINAL CODE AGAINST INFRINGEMENT OR THE LIKE WITH RESPECT
TO ANY COPYRIGHT, PATENT, TRADE SECRET, TRADEMARK OR OTHER PROPRIETARY OR INTELLECTUAL
PROPERTY RIGHT OF ANY THIRD PARTY AND DOES NOT WARRANT THAT THE ORIGINAL CODE DOES NOT
INCLUDE ANY VIRUS, SOFTWARE ROUTINE OR OTHER SOFTWARE DESIGNED TO PERMIT UNAUTHORIZED
ACCESS, TO DISABLE, ERASE OR OTHERWISE HARM SOFTWARE, HARDWARE OR DATA, OR TO PERFORM ANY
OTHER SUCH ACTIONS.
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Any warranties that by law survive the foregoing disclaimers shall terminate 90 days from the date You
received the Original Code.

6. Limitation of Liability.

YOUR SOLE REMEDIES AND GOAHEAD'S ENTIRE LIABILITY ARE SET FORTH ABOVE. IN NO EVENT WILL
GOAHEAD OR ITS DISTRIBUTORS OR DEALERS BE LIABLE FOR DIRECT, INDIRECT, INCIDENTAL OR
CONSEQUENTIAL DAMAGES RESULTING FROM THE USE OF THE ORIGINAL CODE, THE INABILITY TO USE THE
ORIGINAL CODE, OR ANY DEFECT IN THE ORIGINAL CODE, INCLUDING ANY LOST PROFITS, EVEN IF THEY
HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

You agree that GoAhead and its distributors and dealers will not be LIABLE for defense or indemnity with
respect to any claim against You by any third party arising from your possession or use of the Original Code or
the Documentation.

In no event will GoAhead’s total liability to You for all damages, losses, and causes of action (whether in
contract, tort, including negligence, or otherwise) exceed the amount You paid for this product.

SOME STATES DO NOT ALLOW LIMITATIONS ON HOW LONG AN IMPLIED WARRANTY LASTS, AND SOME
STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO
THE ABOVE LIMITATIONS OR EXCLUSIONS MAY NOT APPLY TO YOU. THIS WARRANTY GIVES YOU SPECIFIC
LEGAL RIGHTS AND YOU MAY HAVE OTHER RIGHTS THAT VARY FROM STATE TO STATE.

7. Indemnification by You.

You agree to indemnify and hold GoAhead harmless against any and all claims, losses, damages and costs
(including legal expenses and reasonable counsel fees) arising out of any claim of a third party with respect to
the contents of the Your products, and any intellectual property rights or other rights or interests related
thereto.

8. High-Risk Activities.

The Original Code is not fault-tolerant and is not designed, manufactured or intended for use or resale as online
control equipment in hazardous environments requiring fail-safe performance, such as in the operation of
nuclear facilities, aircraft navigation or communication systems, air traffic control, direct life support machines
or weapons systems, in which the failure of the Original Code could lead directly to death, personal injury, or
severe physical or environmental damage. GoAhead and its suppliers specifically disclaim any express or
implied warranty of fitness for any high-risk uses listed above.

9. Government Restricted Rights.

For units of the Department of Defense, use, duplication, or disclosure by the Government is subject to
restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software
clause at DFARS 252.227-7013. Contractor/manufacturer is GoAhead Software, Inc., 10900 N.E. 8th Street,
Suite 1200, Bellevue, Washington 98004.

If the Commercial Computer Software Restricted rights clause at FAR 52.227-19 or its successors apply, the
Software and Documentation constitute restricted computer software as defined in that clause and the
Government shall not have the license for published software set forth in subparagraph (c)(3) of that clause.

The Original Code (i) was developed at private expense, and no part of it was developed with governmental
funds; (ii) is a trade secret of GoAhead (or its licensor(s)) for all purposes of the Freedom of Information Act;
(iii) is “restricted computer software” subject to limited utilization as provided in the contract between the
vendor and the governmental entity; and (iv) in all respects is proprietary data belonging solely to GoAhead (or
its licensor(s)).

10. Governing Law and Interpretation.

This Agreement shall be interpreted under and governed by the laws of the State of Washington, without
regard to its rules governing the conflict of laws. You hereby consent to the exclusive jurisdiction of the state
and federal courts located in King County, Washington over any disputes arising out of related to this
Agreement. If any provision of this Agreement is held illegal or unenforceable by a court or tribunal of
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competent jurisdiction, the remaining provisions of this Agreement shall remain in effect and the invalid
provision deemed modified to the least degree necessary to remedy such invalidity.

11. Entire Agreement.

This Agreement is the complete agreement between GoAhead and You and supersedes all prior agreements,
oral or written, with respect to the subject matter hereof.

License (OpenSSL)

This is a copy of the current LICENSE file inside the CVS repository.

LICENSE ISSUES

The OpenSSL toolkit stays under a dual license, i.e. both the conditions of the OpenSSL License and the original
SSleay license apply to the toolkit.

See below for the actual license texts. Actually both licenses are BSD-style Open Source licenses. In case of any
license issues related to OpenSSL please contact openssl-core@openssl.org.

OpenSSL License

* Copyright (c) 1998-2008 The OpenSSL Project. All rights reserved.

* Redistribution and use in source and binary forms, with or without modification, are permitted provided that
the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the
following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following
acknowledgment: “This product includes software developed by the OpenSSL Project for use in the
OpenSSL Toolkit. (http://www.openssl.org/)”

4. The names “"OpenSSL Toolkit” and “OpenSSL Project” must not be used to endorse or promote products
derived from this software without prior written permission. For written permission, please contact
openssl-core@openssl.org.

5. Products derived from this software may not be called "OpenSSL” nor may “OpenSSL"” appear in their
names without prior written permission of the OpenSSL Project.

6. Redistributions of any form whatsoever must retain the following acknowledgment: “This product includes
software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)”

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT “AS IS” AND ANY EXPRESSED OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE
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OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

* This product includes cryptographic software written by Eric Young (eay@cryptsoft.com). This product
includes software written by Tim Hudson (tjh@cryptsoft.com).

Original SSLeay License

Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com)

All rights reserved.

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com).

The implementation was written so as to conform with Netscapes SSL.

This library is free for commercial and non-commercial use as long as the following conditions are aheared to.
The following conditions apply to all code found in this distribution, be it the RC4, RSA, lhash, DES, etc., code;
not just the SSL code. The SSL documentation included with this distribution is covered by the same copyright
terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

* Copyright remains Eric Young'’s, and as such any Copyright notices in the code are not to be removed.

* If this package is used in a product, Eric Young should be given attribution as the author of the parts of the
library used.

* This can be in the form of a textual message at program startup or in documentation (online or textual)
provided with the package.

* Redistribution and use in source and binary forms, with or without modification, are permitted provided that
the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of conditions and the following
disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following
acknowledgement: “This product includes cryptographic software written by Eric Young
(eay@cryptsoft.com)”The word “cryptographic” can be left out if the rouines from the library being used are
not cryptographic related :).

4. If youinclude any Windows specific code (or a derivative thereof) from the apps directory (application code)
you must include an acknowledgement: “This product includes software written by Tim Hudson
(tjh@cryptsoft.com)”

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
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PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

* The licence and distribution terms for any publically available version or derivative of this code cannot be
changed. i.e. this code cannot simply be copied and put under another distribution licence [including the GNU
Public Licence.]

/

License (zlib)

/* zlib.h -- interface of the “zlib” general purpose compression library version 1.2.3, July 18th, 2005

Copyright (C) 1995-2005 Jean-loup Gailly and Mark Adler

This software is provided “as-is”, without any express or implied warranty. In no event will the authors be held
liable for any damages arising from the use of this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and
to alter it and redistribute it freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must not claim that you wrote the original
software. If you use this software in a product, an acknowledgment in the product documentation would be
appreciated but is not required.

2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the
original software.

3. This notice may not be removed or altered from any source distribution.

Jean-loup Gailly jloup@gzip.org

Mark Adler madler@alumni.caltech.edu
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